
Revit FAQs: 63 questions with answers!

Description

Revit, a powerful Building Information Modeling (BIM) software developed by Autodesk, has become
an industry standard for architects, engineers, and construction professionals. Its comprehensive set of
tools allows users to create detailed 3D models, generate 2D drawings, and track various stages of a
building’s lifecycle, from concept to construction and later demolition. However, as with any complex
software, users often have questions about how to perform specific tasks or overcome challenges they
encounter while working in Revit. This article aims to answer 63 of the most frequently asked questions
about Revit, providing a valuable resource for both new and experienced users.

Revit FAQs: 63 questions with answers!

1. How to array along a curve in Revit?

In Revit, there isn’t a direct tool to array along a curve. However, you can use a workaround by
creating a path and then using the “Divide Path” function to create points along the curve. You can
then place your object at each of these points.

2. How to open BIM 360 in Revit?

To open BIM 360 in Revit, go to the “File” menu, then select “Open”, and then “BIM 360”. This will open
a dialog box where you can select the BIM 360 project you want to open.

3. How to change the host of a family in Revit?

To change the host of a family in Revit, you need to edit the family. Open the family editor, select the
family you want to change, and then select a new host in the “Properties” panel.

4. How to make a railing slope in Revit?

To make a railing slope in Revit, you need to create a path for the railing that follows the slope. You
can do this by drawing a line or a spline along the slope, and then using this as the path for the railing.

5. How to use model line in Revit?

Model lines in Revit are used to create 2D and 3D geometry that is not associated with a specific view.
To use a model line, go to the “Annotate” tab, select “Detail Line”, and then select “Model Line”. You
can then draw the line in the view you are working in.
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6. How to add a revision to a sheet in Revit?

To add a revision to a sheet in Revit, go to the “View” tab, then “Sheet Composition”, and then
“Revisions”. In the “Revisions” dialog box, you can add a new revision, specify the details, and then
apply it to the sheet.

7. How to add grass material in Revit?

To add grass material in Revit, go to the “Manage” tab, then “Materials”. In the “Materials” dialog box,
you can create a new material and specify its properties, including its appearance as grass.

8. How to add leader to tag in Revit?

To add a leader to a tag in Revit, select the tag, and then in the “Properties” panel, check the box for
“Leader”. You can then adjust the leader as needed.

9. How to add scale parameter in Revit?

To add a scale parameter in Revit, you need to create a new shared parameter. Go to the “Manage”
tab, then “Shared Parameters”, and create a new parameter with the desired settings. You can then
add this parameter to your families or projects as needed.

10. How to adjust cut plane in Revit?

To adjust the cut plane in Revit, go to the “Properties” panel, and under “View Range”, adjust the “Cut
Plane” setting. This will change the height at which the view cuts through the model.

11. How to adjust room boundary in Revit?

To adjust a room boundary in Revit, select the room, and then use the “Edit Boundary” tool. You can
then adjust the boundary lines as needed.

12. How to change current revision description in Revit?

To change the current revision description in Revit, go to the “View” tab, then “Sheet Composition”, and
then “Revisions”. In the “Revisions” dialog box, select the revision you want to change, and then edit
the description.

13. How to change pipe system abbreviation in Revit?

To change the pipe system abbreviation in Revit, go to the “Manage” tab, then “Project Settings”, and
then “Pipe Settings”. In the “Pipe Settings” dialog box, you can change the abbreviation for each pipe
system.
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14. How to change section head color in Revit?

To change the section head color in Revit, go to the “Manage” tab, then “Additional Settings”, and then
“Line Styles”. In the “Line Styles” dialog box, you can change the color of the section head line style.

15. How to change the phase of a room in Revit?

To change the phase of a room in Revit, select the room, and then in the “Properties” panel, change
the “Phase” setting to the desired phase.

16. How to create a dummy schedule in Revit?

To create a dummy schedule in Revit, go to the “View” tab, then “Create”, and then
“Schedule/Quantities”. In the “New Schedule” dialog box, select the category you want to schedule,
and then add the fields you want to include in the schedule. You can then leave the schedule empty to
serve as a dummy schedule.

17. How to create a new sheet discipline in Revit?

To create a new sheet discipline in Revit, go to the “Manage” tab, then “Project Settings”, and then
“Project Information”. In the “Project Information” dialog box, you can add a new discipline to the
“Disciplines” list.

18. How to create a sloped beam system in Revit?

To create a sloped beam system in Revit, first create a sloped work plane. Then, go to the “Structure”
tab, select “Beam System”, and draw the beam system on the sloped work plane.

19. How to create a solid in Revit?

To create a solid in Revit, go to the “Massing & Site” tab, select “In-Place Mass”, and then use the
“Create” tools to create the solid geometry.

20. How to create a text table in Revit?

To create a text table in Revit, go to the “Annotate” tab, select “Text”, and then “Text Box”. You can
then draw the table and add text to it.

21. How to create category parameters in Revit?

To create category parameters in Revit, go to the “Manage” tab, then “Project Parameters”. In the
“Project Parameters” dialog box, you can add a new parameter and assign it to the desired categories.
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22. How to create layer in Revit?

Revit does not use layers in the same way as other CAD programs. Instead, it uses categories and
subcategories to organize elements. You can create new subcategories in the “Object Styles” dialog
box, which is found under the “Manage” tab.

23. How to create pipe family in Revit?

To create a pipe family in Revit, go to the “File” menu, select “New”, and then “Family”. In the “New
Family – Select Template File” dialog box, select the “Pipe” template, and then use the family editor to
create the pipe family.

24. How to create reference line in Revit?

To create a reference line in Revit, go to the “Annotate” tab, select “Detail Line”, and then “Reference
Line”. You can then draw the reference line in the view you are working in.

25. How to draw 3D line in Revit?

To draw a 3D line in Revit, you need to use the “Model Line” tool. Go to the “Annotate” tab, select
“Detail Line”, and then “Model Line”. You can then draw the line in a 3D view.

26. How to edit area boundaries in Revit?

To edit area boundaries in Revit, select the area boundary you want to edit, and then use the “Edit
Boundary” tool. You can then adjust the boundary lines as needed.

27. How to edit profile family in Revit?

To edit a profile family in Revit, go to the “Project Browser”, find the family you want to edit, right-click
on it, and select “Edit”. This will open the family in the family editor, where you can make your changes.

28. How to enlarge a 3D view in Revit?

To enlarge a 3D view in Revit, you can use the “Zoom” tool in the view controls. You can also use the
scroll wheel on your mouse to zoom in and out.

29. How to find a section in plan Revit?

To find a section in a plan view in Revit, go to the plan view, and look for the section markers. You can
then select the marker and use the “Go to View” tool to open the section view.

30. How to get a roof plan in Revit?

To get a roof plan in Revit, go to the “View” tab, select “Plan Views”, and then “Roof Plan”. You can
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then select the level you want the roof plan for.

31. How to install US Imperial in Revit?

When you install Revit, it should automatically include both Metric and Imperial libraries. If you need to
switch to the US Imperial system, you can do so in the “Project Units” dialog box, which is found under
the “Manage” tab.

32. How to make arrow leader in Revit?

To make an arrow leader in Revit, go to the “Annotate” tab, select “Text”, and then “Text with Leader”.
You can then draw the leader and add your text.

33. How to measure angles in Revit?

To measure angles in Revit, use the “Measure” tool, which is found under the “Annotate” tab. Select
“Measure Between Two References”, and then select the two lines or points you want to measure the
angle between.

34. How to move sheet in project browser Revit?

In the Project Browser in Revit, you can drag and drop sheets to reorder them. If you want to move a
sheet to a different subset, you can right-click on the sheet, select “Move to Subset”, and then select
the subset you want to move the sheet to.

35. How to open a DXF file in Revit?

To open a DXF file in Revit, go to the “Insert” tab, select “Import CAD”, and then select the DXF file you
want to import.

36. How to overlay CAD drawings in Revit?

To overlay CAD drawings in Revit, go to the “Insert” tab, select “Link CAD” or “Import CAD”, and then
select the CAD file you want to overlay. In the “Import/Link CAD” dialog box, make sure to set the
positioning to “Overlay”.

37. How to put an object on top of another in Revit?

To put an object on top of another in Revit, you can use the “Move” tool to position the object in the
desired location. If you need to adjust the elevation of the object, you can do so in the “Properties”
panel.

38. How to recover crashed Revit file?

If Revit crashes, you can recover your work by reopening Revit and selecting “Recover Unsaved
Changes” when the “Data Recovery” dialog box appears. This will open a list of projects that have
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unsaved changes, and you can select the one you want to recover.

39. How to remove phases in Revit?

To remove phases in Revit, go to the “Manage” tab, then “Phasing”, and then “Phases”. In the
“Phases” dialog box, select the phase you want to remove, and then click “Delete”.

40. How to resize viewport in Revit?

To resize a viewport in Revit, select the viewport, and then use the control handles to adjust the size.
You can also enter specific dimensions in the “Properties” panel.

41. How to schedule coordinates in Revit?

To schedule coordinates in Revit, you need to create a shared parameter for the coordinates, and then
add this parameter to your schedule. You can then use the “Report Coordinates” tool to populate the
parameter with the coordinates of each element.

42. How to schedule spot coordinates in Revit?

To schedule spot coordinates in Revit, you need to create a spot coordinate for each point you want to
schedule. You can then create a schedule that includes the “Spot Coordinate” category, and add the
necessary fields to the schedule.

43. How to see floor below in Revit?

To see the floor below in a plan view in Revit, you can use the “Underlay” property in the “Properties”
panel. Set the “Underlay” to the level below the one you are currently viewing.

44. How to split a wall in Revit?

To split a wall in Revit, use the “Split Element” tool, which is found under the “Modify” tab. Select the
wall you want to split, and then click on the point where you want to split the wall.

45. How to turn off ortho mode in Revit?

To turn off ortho mode in Revit, you can press the “F8” key on your keyboard. You can also click on the
“Ortho Mode” button in the status bar to toggle it on and off.

46. How to turn on elevation markers in Revit?

To turn on elevation markers in Revit, go to the “View” tab, select “Visibility/Graphics”, and then check
the box for “Elevation Marks” in the “Annotations” category.
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47. How to unlock a view on a sheet in Revit?

To unlock a view on a sheet in Revit, select the view on the sheet, and then in the “Properties” panel,
uncheck the box for “Lock View Position”.

48. How to use scope boxes in Revit?

Scope boxes in Revit are used to define a specific area of the model for a view. To use a scope box,
go to the “View” tab, select “Scope Box”, and then draw the scope box in the view. You can then
assign the scope box to a view in the “Properties” panel.

49. Does Revit have spell check?

Yes, Revit does have a spell check feature. You can access it by going to the “Annotate” tab, and then
selecting “Spell Check”. This will check the spelling in all text elements in the current view.

50. How to add notes to a schedule in Revit?

To add notes to a schedule in Revit, you can add a “Text” parameter to the schedule. In the “Schedule
Properties” dialog box, click “Add”, and then select “Text” as the parameter type. You can then enter
your notes in this parameter for each element in the schedule.

51. How to adjust viewport size in Revit?

To adjust the size of a viewport in Revit, select the viewport on the sheet. Blue control handles will
appear at the corners and midpoints of the viewport boundary. Click and drag these handles to adjust
the size of the viewport.

52. How to do cross section in Revit?

To create a cross section in Revit, go to the “View” tab, select “Section”, and then “Cross Section”. You
can then draw the section line in the view you are working in. The section view will automatically be
created and can be accessed from the Project Browser.

53. How to show stairs in RCP (Reflected Ceiling Plan) in Revit?

To show stairs in a Reflected Ceiling Plan (RCP) in Revit, you need to adjust the view range of the
RCP to include the stairs. Go to the “Properties” panel, and under “View Range”, adjust the “Top” and
“Cut Plane” settings so that they include the height of the stairs.

54. Revit can’t adjust scope box?

If you’re unable to adjust a scope box in Revit, it may be because the scope box is locked. To unlock it,
select the scope box, and in the “Properties” panel, uncheck the box for “Lock 3D Extents”.
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55. Revit can’t change linked model color?

If you’re unable to change the color of a linked model in Revit, it may be because the linked model is
set to “By Linked View” in the “Visibility/Graphics Overrides” settings. To change the color, you need to
set it to “Custom” and then adjust the color settings.

56. Revit can’t get out of edit mode?

If you’re stuck in edit mode in Revit, you can exit by clicking the “Finish Editing” button in the ribbon. If
this button is not available, it may be because you are in a dialog box or another mode that needs to
be closed first.

57. Revit can’t select linked model?

If you’re unable to select a linked model in Revit, it may be because the linked model is set to “Not
Selectable” in the “Visibility/Graphics Overrides” settings. To make it selectable, you need to change
this setting.

58. What is bind link in Revit?

“Bind Link” in Revit is a function that allows you to incorporate a linked Revit model into your current
project as a group. This can be useful if you need to edit the elements of the linked model directly, but
it should be used with caution as it can significantly increase the size of your project file.

59. What is the use of copy monitor in Revit?

The “Copy/Monitor” tool in Revit is used to create a copy of elements from a linked model in your
current project, and to monitor these elements for changes. This is useful in collaborative projects
where multiple disciplines are working on separate models, as it allows you to keep track of changes
made in the linked models.

60. Where is Revit library located?

The Revit library is typically located in the “Libraries” folder in the Revit installation directory. The exact
path can vary depending on your version of Revit and your operating system.

61. Why is link Revit greyed out?

If the “Link Revit” option is greyed out, it may be because you are in a view or mode that does not
support linking Revit models, such as a family editor view. It can also be because you do not have the
necessary permissions to link models in a workshared project.

62. How to add anchor bolts in Revit?

To add anchor bolts in Revit, you can use the “Component” tool, which is found under the
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“Architecture” or “Structure” tab. Click “Component”, then “Place a Component”, and select the anchor
bolt family from the list. You can then place the anchor bolts in your model.

63. How to create a site plan view in Revit?

To create a site plan view in Revit, go to the “View” tab, select “Plan Views”, and then “Site Plan”. You
can then select the level you want the site plan for.

Conclusion

Whether you’re a seasoned Revit user or a beginner just starting to explore the software’s capabilities,
we hope this comprehensive FAQ has provided you with valuable insights and solutions to your Revit-
related queries. Remember, mastering Revit is a journey, and every challenge encountered is an
opportunity to learn and grow. As the software continues to evolve, so too will the questions and
answers surrounding its use. So, keep exploring, keep asking questions, and keep pushing the
boundaries of what you can achieve with Revit.
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