
How to Paste to Original Coordinates in Revit?

Description

In the world of architectural design and construction, Revit has emerged as a powerful software tool for
building information modeling (BIM). With its extensive range of features, Revit allows architects,
engineers, and designers to create accurate 3D models of buildings and efficiently manage various
design elements. One important aspect of working in Revit is the ability to paste elements to their
original coordinates, ensuring precise placement within a project. In this article, we will explore different
methods and techniques to achieve this in Revit.

Pasting to Original Coordinates in Revit

Understanding the Concept

When working with complex architectural models, it is common to need to copy and paste elements
within the project. However, merely copying and pasting can lead to misalignment if the elements are
not placed in their original coordinates. Pasting to original coordinates ensures that the copied
elements maintain their exact position relative to the project’s origin.

Method 1: Using the Clipboard

Revit provides a straightforward way to paste elements to their original coordinates using the
Clipboard. Here’s how you can do it:

1. Copy the desired element(s) using the Copy command (Ctrl+C or right-click and select Copy).
2. In the desired location, use the Paste Aligned to Same Place command (Ctrl+Alt+V or right-click

and select Paste Aligned to Same Place). This ensures that the elements are pasted at their
original coordinates.

Method 2: Utilizing Shared Coordinates
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Revit offers the ability to use shared coordinates, which allows multiple linked models to align properly.
By utilizing shared coordinates, you can paste elements from one model to another while maintaining
their original positioning. Follow these steps:

1. Ensure that both the source and destination models have shared coordinates established. If not,
you can set them up by using the Publish Coordinates and Acquire Coordinates commands.

2. In the source model, select the desired elements and choose the Copy command.
3. Switch to the destination model, navigate to the desired location, and use the Paste Aligned to 

Same Place command to paste the elements while preserving their original coordinates.

Method 3: Coordinating Across Multiple Views

Revit allows you to work with multiple views within a project, each displaying different aspects of the
design. To paste elements to their original coordinates across different views, follow these steps:

1. Open both the source and destination views side by side within Revit.
2. In the source view, select the elements you want to copy and use the Copy command.
3. Switch to the destination view, navigate to the desired location, and choose the Paste Aligned to 

Same Place command to paste the elements while maintaining their original coordinates.

Method 4: Using Guide Grids

Guide grids in Revit are a useful tool for aligning elements precisely. By utilizing guide grids, you can
easily paste elements to their original coordinates. Here’s how you can do it:

1. Set up guide grids in both the source and destination views to ensure consistent alignment.
2. In the source view, select the elements you want to copy and choose the Copy command.
3. Switch to the destination view, navigate to the desired location, and utilize the guide grids to align

the copied elements to their original coordinates.
4. Use the Paste Aligned to Same Place command to complete the process.

FAQ

1. How do I copy UCS from one drawing to another?

To copy the User Coordinate System (UCS) from one drawing to another in AutoCAD, follow these
steps:

1. Open the source drawing that contains the desired UCS.
2. Type UCS in the command line and press Enter.
3. Select the UCS icon and choose the Copy option.
4. Open the destination drawing where you want to copy the UCS.
5. Type UCS in the command line again and press Enter.
6. Select the UCS icon and choose the Paste option.
7. The UCS from the source drawing will be copied to the destination drawing.
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2. How do you move an object to the origin in Revit?

To move an object to the origin in Revit, you can use the Align tool. Here’s how:

1. Select the object(s) you want to move.
2. Activate the Modify tab in the ribbon.
3. In the Modify panel, click on the Align tool.
4. Choose the reference object that represents the origin (e.g., a reference point or a model line).
5. Click on the desired reference point on the reference object.
6. Click on the corresponding point on the object you want to move.
7. The selected object will be moved to the origin.

3. How do you change the origin in Revit?

In Revit, the project origin is fixed and cannot be changed. However, you can redefine the project base
point or internal origin. Here’s how:

1. Go to the Manage tab in the ribbon.
2. In the Project Location panel, click on Position.
3. Select Acquire Coordinates.
4. Choose Specify Coordinates at Point.
5. Click on a point in the drawing area to define the new project base point or internal origin.
6. Click OK to confirm the new origin.

4. Can you copy with a base point in Revit?

Yes, you can copy elements with a base point in Revit. Here’s how:

1. Select the element(s) you want to copy.
2. Activate the Modify tab in the ribbon.
3. In the Clipboard panel, click on the Copy tool.
4. Choose the desired base point from which you want to copy the elements.
5. Click on the base point in the drawing area.
6. Move the cursor to the desired location and click to place the copied elements.

5. How do you align coordinates in Revit?

To align coordinates in Revit, you can use various methods depending on your requirements. Here are
two commonly used approaches:

Method 1: Using shared coordinates 
1. Ensure that both the source and destination models have shared coordinates established.
2. Copy the elements from the source model.
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3. Paste the elements into the destination model using the Paste Aligned to Same Place
command.

Method 2: Using guide grids 
1. Set up guide grids in both the source and destination views.
2. Copy the elements from the source view.
3. Paste the elements into the destination view using the Paste Aligned to Same Place

command, aligning them to the guide grids.

These methods ensure that the elements maintain their original coordinates or align with specified
reference points, resulting in coordinated placement.

6. How do I geolocate a Revit model?

To geolocate a Revit model, you can follow these steps:

1. Open the Revit model you want to geolocate.
2. Go to the Manage tab in the ribbon.
3. In the Location panel, click on Acquire Location.
4. Select Auto – By Address or Manual – By Latitude and Longitude. 

If selecting Auto – By Address, enter the project address and click OK.
If selecting Manual – By Latitude and Longitude, enter the latitude and longitude
coordinates and click OK.

5. Revit will geolocate the model based on the provided address or coordinates.

Geolocating a Revit model allows for accurate positioning and alignment with the real-world site.

7. How do you move a coordination model in Revit?

To move a coordination model in Revit, you can use the Move tool. Here’s how:

1. Activate the Collaborate tab in the ribbon.
2. In the Link panel, click on Move.
3. Select the coordination model you want to move.
4. Click on a reference point on the coordination model to specify the base point.
5. Move the cursor to the desired location and click to place the coordination model.

Moving a coordination model allows for better coordination and visualization within the Revit project.

8. How do you paste in Revit?

To paste elements in Revit, you can use the Paste command. Here’s how:

1. Copy the desired element(s) using the Copy command.
2. In the desired location, use the Paste command (Ctrl+V or right-click and select Paste).
3. The copied element(s) will be pasted at the specified location.
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9. How do you copy in Revit?

To copy elements in Revit, you can use the Copy command. Here’s how:

1. Select the element(s) you want to copy.
2. Activate the Modify tab in the ribbon.
3. In the Clipboard panel, click on the Copy tool.
4. Move the cursor to the desired location and click to place the copied elements.

10. How do you copy a beam in Revit?

To copy a beam in Revit, you can use the Copy command. Here’s how:

1. Select the beam you want to copy.
2. Activate the Modify tab in the ribbon.
3. In the Clipboard panel, click on the Copy tool.
4. Move the cursor to the desired location and click to place the copied beam.

Copying beams allows for efficient replication of structural elements in a Revit project.

Please note that Revit’s terminology may refer to beams as “structural framing” or “structural members”
depending on the version.

11. Can you copy an xref without changing the original?

In AutoCAD, you can copy an external reference (xref) without changing the original file. Here’s how:

1. Open the drawing that contains the xref you want to copy.
2. Type XREF in the command line and press Enter.
3. In the External References palette, select the xref you want to copy.
4. Right-click on the selected xref and choose Copy.
5. Open the destination drawing where you want to paste the copied xref.
6. Type XREF in the command line and press Enter.
7. Right-click in the External References palette and choose Paste.
8. Specify the insertion point for the copied xref in the destination drawing.

Copying an xref allows you to reuse the referenced file without modifying the original.

12. How do you bind an xref?

To bind an external reference (xref) in AutoCAD, follow these steps:

1. Open the drawing that contains the xref you want to bind.
2. Type XREF in the command line and press Enter.
3. In the External References palette, select the xref you want to bind.
4. Right-click on the selected xref and choose Bind.
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5. In the Bind Xrefs dialog box, choose the desired options, such as whether to bind as an
attachment or an overlay.

6. Click OK to bind the xref to the drawing.

Binding an xref incorporates the referenced file into the current drawing, eliminating the external
reference.

13. How do you explode an xref?

To explode an external reference (xref) in AutoCAD, use the XREF and EXPLODE commands. Here’s
how:

1. Open the drawing that contains the xref you want to explode.
2. Type XREF in the command line and press Enter.
3. In the External References palette, select the xref you want to explode.
4. Right-click on the selected xref and choose Open Reference.
5. Type EXPLODE in the command line and press Enter.
6. Select the objects you want to explode within the xref.
7. Press Enter to complete the explode operation.

Exploding an xref converts the referenced elements into individual entities within the current drawing.

14. How do I copy a block from one drawing to another?

To copy a block from one drawing to another in AutoCAD, you can use the WBLOCK command.
Here’s how:

1. Open the drawing that contains the block you want to copy.
2. Type WBLOCK in the command line and press Enter.
3. In the Write Block dialog box, select the block(s) you want to copy.
4. Choose the destination location and name for the new drawing file.
5. Click OK to create the new drawing file containing the copied block(s).
6. Open the destination drawing where you want to insert the copied block(s).
7. Type INSERT in the command line and press Enter.
8. In the Insert dialog box, browse and select the newly created drawing file.
9. Specify the insertion point and scale for the copied block(s).

10. Click OK to insert the copied block(s) into the destination drawing.

Copying blocks between drawings allows for efficient reuse of standard components and elements.

15. How do I copy from one layout to another in AutoCAD?

To copy objects from one layout to another in AutoCAD, follow these steps:

1. Open the drawing containing the source layout.
2. Type LAYOUT in the command line and press Enter.
3. In the Layout tab, select the source layout tab.
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4. Type COPYBASE in the command line and press Enter.
5. Select the objects you want to copy from the source layout.
6. Press Enter to complete the selection.
7. Type MSPACE in the command line and press Enter to switch to Model Space.
8. Type LAYOUT in the command line and press Enter.
9. In the Layout tab, select the destination layout tab.

10. Type PASTECLIP in the command line and press Enter.
11. Specify the insertion point for the copied objects in the destination layout.

Copying objects between layouts allows for efficient duplication of design elements within a multi-
layout drawing.

16. How do I copy and paste an isometric view in AutoCAD?

To copy and paste an isometric view in AutoCAD, you can use the COPYBASE and PASTEBLOCK
commands. Here’s how:

1. Activate the Isometric view in AutoCAD.
2. Type COPYBASE in the command line and press Enter.
3. Select the objects you want to copy in the isometric view.
4. Press Enter to complete the selection.
5. Type PASTEBLOCK in the command line and press Enter.
6. Specify the insertion point for the copied objects.
7. The copied objects will be pasted as a block in the same isometric view or another location.

Copying and pasting an isometric view allows for quick replication of design elements within an
isometric drawing.

17. Can you move the internal origin in Revit?

No, it is not possible to move the internal origin in Revit. The internal origin, also known as the project
base point, is a fixed reference point within the Revit model. It serves as the origin for various
calculations and coordinates in the project. While you cannot move the internal origin, you can redefine
the project base point to a new location, as explained in an earlier question.

18. How do you show the project base point in Revit?

To show the project base point in Revit, follow these steps:

1. Go to the Manage tab in the ribbon.
2. In the Project Location panel, click on Position.
3. Select Acquire Coordinates.
4. Choose Specify Coordinates at Point.
5. In the Specify Coordinates dialog box, select the Show Project Base Point option.
6. Click OK to confirm and show the project base point in the Revit view.

CADDIKT
https://caddikt.com/

https://c
addikt.com/

Page 7
https://caddikt.com/



Showing the project base point helps visualize the reference point within the Revit project.

19. What is the project base point in Revit?

The project base point in Revit is a fixed reference point within a project that serves as the origin for
various coordinates and calculations. It represents a specific location in the real-world site or project
context. The project base point is used for positioning elements, coordinating with shared coordinates,
and conducting accurate calculations within the Revit model.

20. What is origin to origin in Revit?

“Origin to Origin” is a coordinate transformation option available when linking Revit models. When
linking models using the “Origin to Origin” option, the linked model’s origin aligns with the host model’s
origin, ensuring that both models share the same reference point. This alignment facilitates
coordination and accurate positioning of elements between linked models, maintaining consistency and
accuracy in the overall project.

Conclusion

Accurate placement of elements within a Revit project is crucial for maintaining precision and
consistency in architectural design. By utilizing the methods outlined in this guide, you can paste
elements to their original coordinates, ensuring that your design remains aligned and true to its
intended position. Whether you choose to use the Clipboard, shared coordinates, multiple views, or
guide grids, Revit offers a range of tools to facilitate this process. With practice and familiarity, you will
become proficient in pasting to original coordinates in Revit, enhancing your productivity and efficiency
in architectural design and BIM workflows.
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