
How to Open Higher Version Revit Files in
Older Versions

Description

Working with Autodesk Revit is a vital part of the architecture, engineering, and construction (AEC)
industries. However, professionals often encounter the challenge of opening higher version Revit files
in older versions of the software. In this comprehensive guide, we will explore various solutions to this
common problem, ensuring seamless collaboration between team members using different Revit
versions.

TAKEAWAY

While Autodesk Revit does not provide built-in backward compatibility, there are several methods
available to open higher version Revit files in older versions. These include exporting to IFC, using
Autodesk Revit’s Save-As option (if available), utilizing third-party applications, or manually transferring
elements between files. Remember to exercise caution and adhere to best practices, such as
maintaining backups and testing converted files, to minimize potential issues. Staying informed about
Revit updates and fostering clear communication within your team can also help reduce compatibility
challenges in the long run.

Understanding Revit Backward Compatibility

Autodesk Revit, like many software applications, is not inherently backward compatible. As a result,
opening and editing a Revit file created in a newer version using an older version can be challenging.
The following sections detail different methods to tackle this issue.

Method 1: Export to IFC

The Industry Foundation Classes (IFC) format is an open file format used for exchanging data between
different BIM software applications. Here’s how you can export a higher version Revit file to IFC:
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1. Open the higher version Revit file.
2. Click on the File tab, then select Export.
3. Choose IFC from the list of export options.
4. In the Export IFC window, configure the desired settings and click Export.

To import the IFC file in an older Revit version:

1. Open the older version of Revit.
2. Click on the File tab, then select Open.
3. Choose the exported IFC file and click Open.

Note: Exporting to IFC may result in loss of certain elements or features that are unique to Revit. 
However, this method is generally effective for preserving geometry and other basic information.

Method 2: Save to an Earlier Version Using Autodesk Revit Save-As

In some cases, Autodesk provides updates to Revit that allow users to save their files in earlier
versions. To check if this option is available:

1. Open the higher version Revit file.
2. Click on the File tab, then select Save As.
3. In the Save As window, look for a dropdown menu labeled Save as type or Files of type.
4. If available, select the desired older Revit version from the list.

Note: The ability to save to earlier versions depends on the specific Revit updates and may not always 
be available.

Method 3: Use Third-Party Applications

Several third-party applications can help convert higher version Revit files to a format compatible with
older versions. Some popular options include:

Revit File Converter: This online tool allows users to convert their Revit files to a compatible
format for older versions. However, it may have limitations in terms of file size and conversion
accuracy.
Revit Family Downgrade: This plugin is designed for downgrading Revit family files to an earlier
version. It may not be suitable for complex projects but can be helpful for individual family files.

Note: The effectiveness of third-party applications may vary, and users should test the converted files 
for accuracy and completeness before relying on them for critical work.

Method 4: Manual Transfer of Elements

In situations where the above methods are not viable, you can opt for a manual transfer of elements
between Revit files. This process involves copying and pasting elements from the higher version file to
a new file created in the older version. Here’s how:
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1. Open both the higher version and older version Revit files.
2. In the higher version file, select the elements you want to transfer.
3. Use the Copy to Clipboard feature or press Ctrl+C to copy the selected elements. 4. Switch to

the older version Revit file.

5. Use the Paste from Clipboard feature or press Ctrl+V to paste the copied elements into the
older version file.

Note: This method can be time-consuming and may not capture all data associated with the elements. 
Additionally, certain features or elements may not be compatible with the older version, resulting in loss 
of information or functionality.

Precautions and Best Practices

While the methods outlined above can help you open higher version Revit files in older versions, it’s
essential to keep the following precautions and best practices in mind:

1. Always make a backup of your original Revit files before attempting any conversion or
downgrade process.

2. Test the converted or downgraded files to ensure they maintain their integrity and functionality.
3. Communicate with your team members about the Revit versions being used and establish a

common version if possible to minimize compatibility issues.
4. Stay updated on Autodesk Revit updates and patches, which may introduce additional backward

compatibility options.

FAQ: How to Open Higher Version Revit Files in Older Versions

1. Can you save Revit to an older version?

Yes, it is possible to save a Revit file to an older version, but not directly through the standard Save or
Save As commands. As mentioned earlier, Autodesk occasionally provides updates that allow users to
save their files in earlier versions. You can also use third-party applications or plugins to downgrade a
Revit file. Another option is to export the file to IFC, which can be opened in older versions of Revit,
albeit with some loss of information and functionality.

2. Can you downgrade a Revit file?

Yes, you can downgrade a Revit file, but it may require using third-party applications, plugins, or the
IFC format. Downgrading a Revit file is not a built-in feature, and you may experience some loss of
data or functionality during the process. Before downgrading, ensure you have a backup of the original
file and thoroughly test the downgraded file for accuracy and completeness.

3. How do I save a Revit file as a lower version?

To save a Revit file as a lower version, you can use one of the methods mentioned earlier in the article,
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such as exporting to IFC, using a third-party application, or manually transferring elements between
files. If Autodesk has provided an update that allows saving to an earlier version, you can also use the
Save As command with the appropriate file type selected.

4. Can you open a 2020 Revit file in 2019?

Opening a 2020 Revit file in 2019 is not directly possible due to the lack of backward compatibility.
However, you can use the previously mentioned methods like exporting to IFC, using third-party
applications, or manually transferring elements to make the file compatible with the 2019 version.

5. How do I download an older version of Revit?

To download an older version of Revit, follow these steps:

1. Log in to your Autodesk Account at manage.autodesk.com.
2. Click on the “All Products & Services” tab.
3. Find Revit in the list of products and click the “Downloads” button next to it.
4. In the Downloads window, select the desired version and language, then click “Download.”

Please note that downloading older versions of Revit may be subject to the terms of your Autodesk
subscription or maintenance plan.

6. What version of Revit is my file?

To determine the version of a Revit file, you can use a free online service like RevitVersionChecker or
FileInfo. These tools will analyze your file and provide information about the Revit version used to
create it. Alternatively, you can attempt to open the file in Revit and check the error message that
appears if it is not compatible with your installed version; the message usually indicates the required
version.

7. How do I convert Revit to AutoCAD?

To convert a Revit file to AutoCAD, follow these steps:

1. Open the Revit file.
2. Go to the “File” tab and click “Export.”
3. Choose “CAD Formats” and select “DWG” or “DXF” depending on your requirements.
4. Configure the export settings and click “Export.”

Please note that converting from Revit to AutoCAD may result in the loss of certain BIM elements and
features, as AutoCAD is not a native BIM application.

8. Can Revit LT open Revit files?
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Yes, Revit LT can open Revit files created in the full version of the software. However, certain
advanced features and components available in the full version may not be accessible or editable in
Revit LT. This is because Revit LT is a more affordable and limited version of the software, designed 
for smaller firms and individual users who do not require all the advanced features of the full version.

9. How do I update my Revit?

To update your Revit software, follow these steps:

1. Ensure you are logged in to your Autodesk Account in the Autodesk Desktop App.
2. Open the Autodesk Desktop App on your computer.
3. Navigate to the “Updates” tab.
4. If an update for Revit is available, click on the “Update” button or the “More actions” (…) icon and

select “Install update.”

Alternatively, you can check for updates directly in Revit:

1. Open Revit and click on the “Help” tab.
2. Click “Check for updates.”
3. If an update is available, follow the on-screen instructions to download and install it.

10. Is there a Revit viewer?

Yes, there is a free Revit viewer called Autodesk Viewer. Autodesk Viewer is a web-based application
that allows you to view, share, and comment on Revit files without requiring the full Revit software. You
can upload your Revit files to the Autodesk Viewer and share the link with others who need to view the
file but do not have access to Revit.

11. How do I save a Revit template as a project?

To save a Revit template as a project, follow these steps:

1. Open the Revit template file.
2. Click on the “File” tab and select “Save As.”
3. In the “Save As” window, choose “Project” from the “Save as type” dropdown menu.
4. Enter a file name and select a location for the new project file, then click “Save.”

This will create a new Revit project file (.rvt) based on the template file (.rte), allowing you to start a
new project with the predefined settings and content from the template.

12. What is an IFC file in Revit?

An IFC (Industry Foundation Classes) file in Revit is an open standard file format used for exchanging
data between different BIM software applications. IFC files enable collaboration between professionals
using various BIM tools, as they can store and share building and construction information in a neutral
and non-proprietary format. Exporting a Revit file to IFC is one method for opening higher version Revit
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files in older versions, although some loss of data and functionality may occur.

13. How do I open IFC files in Revit 2019?

To open IFC files in Revit 2019, follow these steps:

1. Launch Revit 2019.
2. Click on the “File” tab and select “Open.”
3. In the “Open” window, navigate to the location of the IFC file you want to open.
4. Select the IFC file and click “Open.”

Revit 2019 will import the IFC file, allowing you to view and edit its contents within the software.

14. Is Revit 2019 backwards compatible?

Revit 2019, like other versions of Revit, is not inherently backwards compatible. This means you
cannot directly open and edit files created in later versions of Revit within Revit 2019. However, you
can use methods like exporting to IFC, using third-party applications, or manually transferring elements
to make files compatible with Revit 2019.

15. How do you explode in Revit?

To explode imported geometry, such as a DWG or SAT file, in Revit, follow these steps:

1. Select the imported geometry in your Revit project.
2. On the “Modify | Import Instance” tab, click “Explode.”

3. In the “Explode Imported Geometry” window, choose the desired level of detail (Fine, Medium, or
Coarse) for the exploded elements.

4. Click “OK.”

The imported geometry will now be exploded into native Revit elements, which can be manipulated
and modified individually. Keep in mind that exploding geometry may result in a loss of certain attributes
and properties of the original file, and it’s recommended to use this feature cautiously.

It’s important to note that you cannot explode native Revit elements or families in the same way as
imported geometry. Revit is designed to work with parametric elements and encourages users to
modify elements through parameters and constraints rather than direct manipulation. To edit native
Revit elements, consider editing their parameters or working within the family editor if necessary.

Conclusion

Working with different versions of Revit files can be challenging due to the lack of built-in backward
compatibility. However, with a good understanding of the available methods such as IFC exports, third-
party applications, and manual element transfers, it is possible to overcome these challenges and
maintain effective collaboration among team members using different versions of the software. It’s
essential to keep backups of your files, test converted or downgraded files, and communicate with your
team members to ensure smooth workflows. By staying informed about Revit updates and adopting
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best practices, you can minimize compatibility issues and maximize the potential of your BIM projects.
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