
How to Move Origin Point in Solidworks: A Step-
by-Step Guide

Description

Manufacturing, engineering, and building construction all benefit greatly from Solidworks, which is a
highly effective 3D modeling program. The Solidworks origin point is a crucial component. All designs
must have a starting point, or origin, and where you put it can affect how well your final product turns
out. This tutorial will show you how to change the starting position in Solidworks.

Takeaway

Solidworks makes it simple to relocate the model’s starting point with just a few clicks. Modifying the
design’s starting point increases its precision and accuracy. There are a number of ways to accomplish
this in Solidworks, including relocating the origin relative to other features, using a sketch, or making a
new reference axis.

Moving the Origin Point in Solidworks

Moving the origin point in Solidworks is a straightforward process. Here are the steps to follow:

1. Open the Solidworks file that you want to modify.
2. Go to the Features toolbar and click on the “Reference Geometry” dropdown menu.
3. Select “Axis” from the dropdown menu.
4. In the Axis PropertyManager, select the “Reference Axis” option.
5. Click on the “New Reference Axis” button.
6. In the “Axis to create” dialogue box, select the “Origin” option from the “Axis start point” dropdown

menu.
7. Select the “Endpoint” option from the “Axis end point” dropdown menu.
8. Click on the “Reverse Direction” checkbox if you want to change the orientation of the axis.
9. Click on the “Ok” button to create the new reference axis.
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Once you have created the new reference axis, the origin point will move to the endpoint of the new
axis.

Moving the Origin Point Relative to Existing Features

If you want to move the origin point relative to existing features in your Solidworks file, you can use the
“Move/Copy Bodies” feature. Here’s how:

1. Go to the Features toolbar and click on the “Move/Copy Bodies” button.
2. Select the body or bodies that you want to move.
3. In the Move/Copy PropertyManager, select the “Translate/Rotate” option.
4. In the “Translate/Rotate” dialogue box, select the “Reference Geometry” option.
5. Select the axis that you want to use as a reference for the move.
6. Enter the distance or angle that you want to move the body or bodies.
7. Click on the “Ok” button to move the body or bodies.

Moving the Origin Point Using a Sketch

You can also move the origin point in Solidworks using a sketch. Here’s how:

1. Open a new sketch on the Front Plane.
2. Draw a construction line that intersects with the current origin point.
3. Draw a second construction line that intersects with the endpoint where you want to move the

origin point.
4. Select the “Origin” option from the “Relations” dropdown menu.
5. Select the current origin point and the intersection of the two construction lines.
6. Click on the “Coincident” option from the “Relations” dropdown menu.
7. Select the endpoint where you want to move the origin point and the intersection of the two

construction lines.
8. Click on the “Ok” button to create the new sketch.
9. Go to the Features toolbar and click on the “Reference Geometry” dropdown menu.

10. Select “Axis” from the dropdown menu.
11. In the Axis PropertyManager, select the “Reference Axis” option.
12. Click on the construction line that intersects with the endpoint where you want to move the origin

point.
13. Click on the “Ok” button to create the new reference axis.

FAQ: How to Move Origin Point in Solidworks?

1. How do I change the coordinate system in SolidWorks?

Changing the coordinate system in SolidWorks is essential when you need to modify a part, assembly
or drawing to meet specific design requirements. To change the coordinate system in SolidWorks, you
need to use the “Reference Geometry” feature.

CADDIKT
https://caddikt.com/

https://c
addikt.com/

Page 2
https://caddikt.com/



First, select the plane or face you want to use as the new coordinate system. Then, go to the
“Reference Geometry” drop-down menu on the Features toolbar and select “Coordinate System.” In
the Coordinate System Property Manager, select “Reference Coordinate System” and choose the
plane or face you selected earlier. You can then adjust the orientation of the new coordinate system as
needed by selecting a reference plane and specifying the angle of rotation.

2. How do you move a part in SolidWorks?

Moving a part in SolidWorks can be achieved by using the “Move/Copy” feature. First, select the part or
parts you want to move. Then, go to the “Move/Copy” drop-down menu on the Features toolbar and
select “Move/Copy Body.” In the Move/Copy Property Manager, choose the “Translate/Rotate” option
and select the reference geometry you want to use for the move. Enter the distance or angle you want
to move the part and click “OK” to apply the move.

Another option for moving a part is to use the “Move Component” feature. This option is useful when
you’re working with assemblies and need to move components within the assembly. Simply select the
component you want to move, click the “Move Component” icon in the Assembly toolbar, and specify
the distance or angle you want to move the component.

3. How do I align an assembly in origin SolidWorks?

To align an assembly in the origin in SolidWorks, you need to use the “Move/Copy” feature. First,
select the assembly you want to align. Then, go to the “Move/Copy” drop-down menu on the Features
toolbar and select “Move/Copy Body.” In the Move/Copy Property Manager, choose the
“Translate/Rotate” option and select the reference geometry you want to use for the move. Enter the
distance or angle you want to move the assembly and click “OK” to apply the move.

Alternatively, you can use the “Mate” feature to align the assembly in the origin. First, select the
component you want to align to the origin. Then, go to the “Mate” drop-down menu on the Assembly
toolbar and select “Coincident.” In the Mate Property Manager, select the origin point and the point on
the component you want to align to the origin. Click “OK” to apply the mate.

4. Where is the move copy bodies SolidWorks?

The “Move/Copy Bodies” feature in SolidWorks is located on the “Features” toolbar. To access it, open
the part or assembly file you want to modify and click on the “Features” toolbar. The “Move/Copy
Bodies” feature is located in the drop-down menu. Click on the feature to open the “Move/Copy Bodies”
Property Manager and begin modifying your model.

5. How do you mate a part to the Origin?

To mate a part to the origin in SolidWorks, you need to use the “Mate” feature. First, select the
component you want to mate to the origin. Then, go to the “Mate” drop-down menu on the Assembly
toolbar and select “Coincident.” In the Mate Property Manager, select the origin point and the point on
the component you want to align to the origin. Click “OK” to apply the mate.
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6. Why is Y up in Solidworks?

The Y-axis is up in SolidWorks because it follows the convention of the Cartesian coordinate system,
which defines the three-dimensional space by using the X, Y, and Z axes. The Y-axis represents the
vertical axis, with positive values increasing in the upward direction. This convention is widely used in
engineering and 3D modeling software, including SolidWorks.

7. How do I use collision detection in Solidworks?

To use collision detection in SolidWorks, you need to enable the “Collision Detection” tool. First, go to
the “Evaluate” drop-down menu on the Command Manager and select “Collision Detection.” In the
Collision Detection Property Manager, select the components you want to check for collisions.
SolidWorks will then highlight any components that are in collision. You can adjust the collision
detection sensitivity and display settings in the Property Manager to customize the results.

8. How do I change the default plane in Solidworks?

To change the default plane in SolidWorks, you need to go to the “Tools” drop-down menu on the
Command Manager and select “Options.” In the Options dialog box, select “System Options” and then
“Default Templates.” Here you can choose which template to use as the default for new parts,
assemblies, and drawings. You can also modify the templates themselves to change the default plane
settings.

9. How do I show origin in Solidworks?

To show the origin in SolidWorks, you need to enable the “Origin” option. First, go to the “View” drop-
down menu on the Command Manager and select “Origin.” SolidWorks will display the origin point in
the graphics area.

10. How do you change isometric view in Solidworks?

To change the isometric view in SolidWorks, you can use the “Isometric View” button in the View 
Orientation toolbar. This toolbar is located on the left-hand side of the SolidWorks window. Click on the 
“Isometric View” button to change the view to the default isometric view. You can also use the “View” 
drop-down menu on the Command Manager and select “Isometric View” to change the view.

Alternatively, you can use the “Orientation” feature to customize your isometric view. Go to the “View”
drop-down menu on the Command Manager and select “Orientation.” In the Orientation dialog box, you
can adjust the orientation of the model using the triad or selecting the appropriate view from the list of
predefined views.

11. How do you move a feature in NX?

To move a feature in NX, you need to use the “Move Object” command. First, select the feature you
want to move. Then, go to the “Edit” drop-down menu on the Command Manager and select “Move
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Object.” In the Move Object dialog box, specify the direction and distance you want to move the
feature. You can also rotate or mirror the feature as needed.

12. How do you move components in Creo?

To move components in Creo, you need to use the “Move” command. First, select the component you
want to move. Then, go to the “Edit” drop-down menu on the Command Manager and select “Move.” In
the Move dialog box, specify the direction and distance you want to move the component. You can
also rotate or mirror the component as needed.

13. Can you move a sketch from one plane to another in SolidWorks?

Yes, you can move a sketch from one plane to another in SolidWorks. To do this, you need to use the
“Move Sketch” command. First, select the sketch you want to move. Then, go to the “Tools” drop-down
menu on the Command Manager and select “Sketch Tools” and then “Move Sketch.” In the Move
Sketch dialog box, specify the new plane and the distance you want to move the sketch. Click “OK” to
apply the move.

14. How do you duplicate a body in SolidWorks?

To duplicate a body in SolidWorks, you need to use the “Mirror” feature. First, select the body you want
to duplicate. Then, go to the “Insert” drop-down menu on the Command Manager and select “Mirror
Part.” In the Mirror Part dialog box, select the plane you want to mirror the body about. You can choose
to keep or discard the original body and specify any additional options as needed. Click “OK” to
duplicate the body.

15. How do you center a part in SolidWorks assembly?

To center a part in a SolidWorks assembly, you need to use the “Move/Copy” feature. First, select the
part you want to center. Then, go to the “Move/Copy” drop-down menu on the Features toolbar and
select “Move/Copy Body.” In the Move/Copy Property Manager, choose the “Translate/Rotate” option
and select the reference geometry you want to use for the move. Enter the distance or angle you want
to move the part so that it is centered in the assembly and click “OK” to apply the move.

Conclusion

An essential part of 3D modeling in SolidWorks is relocating the origin point. Follow this guide’s
instructions and you’ll be able to shift the starting position with complete assurance. Several other
frequently asked questions about SolidWorks have also been addressed, such as how to alter the
coordinate system, relocate parts and features, and properly align assemblies.

While SolidWorks’ many helpful features can certainly speed up the design process, it’s still crucial to
think through the outcomes of any potential tweaks before making them. By investing in your
understanding of SolidWorks and its many features, you’ll be able to produce reliable designs that
adhere to your specifications.

As with anything else, more practice is required for optimal performance. SolidWorks’ many features
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and functions will become second nature the more you use it. And if you’re willing to put in the time and
effort, you can make some truly stunning designs.
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