
How to edit revision text in Revit? (Step by step)

Description

Managing revisions is a critical aspect of any successful architectural, engineering, and construction
(AEC) project, and Autodesk Revit provides robust capabilities for this purpose. Whether you’re an
experienced professional or a beginner, understanding how to edit revision text in Revit is essential for
maintaining the accuracy and reliability of your design data. This article is designed to guide you
through the process, helping you to grasp the intricacies of this task, and to apply them effectively in
your Revit projects.

Revit’s revision features enable you to track changes, add comments, and ensure that all team
members have access to the most up-to-date project information. The power of Revit’s revision
management lies in its flexibility and comprehensiveness – from adjusting revision clouds to changing
revision parameters, the software offers an array of options to help manage your project’s evolution
effectively.

Key Takeaways

1. Autodesk Revit offers powerful and flexible revision management features.
2. You can edit revision text, adjust revision clouds, change revision parameters, and more in Revit.
3. Understanding how to manage revisions in Revit is essential for maintaining the accuracy and

reliability of design data.

How to Edit Revision Text in Revit

Autodesk’s Revit is a powerful architectural design and documentation software that is used widely
across the industry. One important feature that users frequently need to manipulate is the revision text.
Revisions are integral to architectural design processes, and hence understanding how to edit revision
text in Revit becomes essential.
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Understanding Revision Text in Revit

Before we dive into the specifics of editing revision text, let’s briefly cover what revision text is and why
it’s important in Revit:

1. What is Revision Text?: Revision text in Revit refers to the notes and annotations made on a
design to indicate changes, updates, or corrections.

2. Importance of Revision Text: It helps maintain a clear record of changes made to a project,
thus facilitating effective communication within the design team and ensuring everyone stays on
the same page.

Steps to Edit Revision Text in Revit

Now, let’s discuss the step-by-step process to edit revision text in Revit.

1. Open the View: Open the view where the revision cloud is located. Navigate to the ‘View’ tab
and then select the specific view.

2. Select the Revision Cloud: Click on the revision cloud which contains the revision text you want
to edit.

3. Access the Properties: After selecting the revision cloud, go to the ‘Properties’ panel on the left-
hand side of the interface.

4. Edit the Revision Text: In the ‘Properties’ panel, scroll down to the ‘Identity Data’ section. Here,
you’ll find the ‘Comments’ field. This is where you can edit the revision text. Make your desired
changes.

5. Apply Changes: After making your desired changes, make sure to hit ‘Apply’ to save them.

Remember, this procedure may slightly vary depending on the Revit version you are using.

Tips and Tricks for Editing Revision Text in Revit

Here are some additional tips and tricks that can facilitate the process of editing revision text in Revit:

1. Short and Clear Text: Keep your revision text as concise and clear as possible. This makes it
easier for other team members to understand the changes.

2. Use a Consistent Format: Consistency is key in architecture. Make sure to use a consistent
format for your revision text to maintain clarity and uniformity.

3. Assign a Responsible Party: If a particular revision is assigned to a specific person, consider
including their initials in the revision text. This can help keep track of who is responsible for what.

Common Problems While Editing Revision Text in Revit

While Revit is a powerful tool, users can occasionally run into issues while editing revision text. Here
are a few common problems and their solutions:

Problem Solution
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Revision text is not visible
Ensure the view is not obscured by other elements. If necessary, use the
‘Hide in View’ option to temporarily hide obstructing elements.

Cannot select the revision
cloud

Make sure you’re not in a different mode like ‘Detail Line’ or ‘Text Note’.
You need to be in the ‘Modify’ mode to select and edit a revision cloud.

Changes to the revision
text are not saving

Ensure you click ‘Apply’ after making your changes. If the problem
persists, check if you have the necessary permissions to make edits.

For more help and resources on editing revision text in Revit, consider these reliable sources:

Autodesk’s Official Revit User Guide: An official resource from Autodesk that provides a
comprehensive guide to using Revit, including editing revision text.
Revit Forum: A community of Revit users where you can ask questions and share insights about
various Revit operations, including editing revision text.
Autodesk Revit Tutorials on YouTube: A collection of video tutorials on various aspects of Revit,
which might provide visual guidance on editing revision text.

Advanced Techniques for Editing Revision Text in Revit

After mastering the basics of editing revision text in Revit, there are advanced techniques you might
find useful. These techniques can further streamline your workflow and enhance the effectiveness of
your revision notes.

Utilizing Text Styles

In Revit, you can customize text styles to suit your specific needs. This can be particularly useful when
editing revision text.

1. Access Text Styles: Navigate to the “Manage” tab on the top ribbon, then click on “Additional
Settings” and select “Text Types”.

2. Create a New Text Style: Click on the “New…” button to create a new text style.
3. Customize Your Text Style: You can now customize this text style, including factors like font,

size, and color. This text style can then be used for your revision text, ensuring consistency and
clarity.

Leveraging Revision Schedules

Revision schedules in Revit allow you to manage and track all revisions in a project. This can be a
powerful tool when combined with effective revision text.

1. Create a Revision Schedule: Navigate to the “View” tab, then select “Schedules” and “Revision
Schedule”.

2. Customize Your Revision Schedule: You can customize this schedule to suit your needs,
including what information is displayed and how it is formatted.

3. Combine with Revision Text: Use your revision text effectively within this schedule to create a
clear, concise record of all revisions in the project.
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Remember, the above techniques can significantly enhance your ability to edit and manage revision
text in Revit. However, they require a deeper understanding of Revit’s features and functions.
Therefore, make sure to familiarize yourself with these aspects of Revit before diving into these
advanced techniques.

FAQ: How to edit revision text in Revit?

1. How do I add a revision parameter in Revit?

Adding a revision parameter in Revit is a way to create custom metadata for your revisions. To do this,
you first need to access the “Manage” tab on the top ribbon, then click on “Project Parameters”. Here
you can create a new parameter by clicking “Add”, and then assign it to the revisions category. Once
you’ve done that, this parameter will be available to all revisions you create in the project. It’s important
to note that this is a project-specific parameter and won’t be available in other projects unless you
manually add it.

2. How do you edit a revision cloud tag in Revit?

Editing a revision cloud tag in Revit involves adjusting the annotation properties. To do this, first select
the revision cloud you wish to modify. Once selected, go to the “Properties” panel on the left-hand side.
In this panel, you can find the “Tag” property under the “Identity Data” section. Here, you can input your
desired tag text. Remember to hit “Apply” to save the changes. Note that this tag will only be visible in
the view where the revision cloud is placed.

3. How do I create a new revision?

Creating a new revision in Revit is a straightforward process. Navigate to the “View” tab, then select
“Sheet Composition” and click on “Revisions”. In the Revisions dialog box that appears, click on “Add”
to create a new revision. Here, you can input details like the revision number, date, and a brief
description. Make sure to click “OK” to save the new revision. This revision can then be applied to
sheets or views as needed.

or deleting annotations, or adjusting the title block. To access a sheet, go to the “Project Browser”
panel and locate the sheet under the “Sheets” category. Double-click on it to open. You can then use
tools like “Text Note”, “Detail Line”, or “Revision Cloud” to add or edit annotations. If you want to adjust
the title block, select it and access its properties in the “Properties” panel. Changes can include
modifying the sheet name, number, or other parameters associated with the title block.

5. How do I remove revisions from the title block in Revit?
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To remove revisions from the title block in Revit, you first need to access the sheet that has the
revision. Once you’re in the sheet view, select the revision from the revision schedule in the title block.
Then, in the “Properties” panel, change the “Issued” status of the revision to “No”. This will remove the
revision from the title block but will not delete it from the project. Note that revisions can be re-added to
the title block by changing the “Issued” status back to “Yes”.

6. How do you update a title block in Revit?

Updating a title block in Revit involves selecting the title block in the sheet view and then modifying its
properties in the “Properties” panel. This can include changing the name, number, or other details of
the title block. If you need to make more significant changes, such as adding new fields or adjusting
the layout, you need to edit the title block family. This can be done by right-clicking on the title block
and selecting “Edit Family”. After making your changes in the family editor, make sure to load the
updated family back into the project.

7. How do you add revision clouds in Revit?

Revision clouds in Revit can be added by navigating to the “Annotate” tab on the top ribbon, then
clicking on “Revision Cloud”. You can then draw the cloud around the area of the drawing that has
been revised. Once the cloud is drawn, it can be selected and its properties can be adjusted in the
“Properties” panel. This includes linking the cloud to a specific revision by changing the “Revision”
property.

8. How do I change my revision number in Revit 2020?

Changing a revision number in Revit 2020 can be done by accessing the “View” tab, then selecting
“Sheet Composition” and clicking on “Revisions”. In the Revisions dialog box that appears, select the
revision you want to edit and change the “Number” field. Remember to click “OK” to save the changes.
Note that this will change the revision number for all instances where this revision is used in the project.

9. How do you add a revision without a cloud in Revit?

In Revit, revisions are typically associated with revision clouds. However, it’s possible to add a revision
without a cloud by creating the revision in the “Revisions” dialog box (accessible from the “View” tab),
and then applying this revision to a sheet or view using the “Sheet Issues/Revisions” panel. In this
panel, you can select the desired revision from the “Revisions on Sheet” dropdown and click “Add”.
This will add the revision to the sheet or view without a corresponding revision cloud.

In the dialog box that appears, select the revision you want to remove and click “Remove”. This will
remove the revision from the sheet but will not delete it from the project. Note that any revision clouds
linked to the removed revision will not be automatically removed and will need to be deleted manually if
desired.

11. Where is the revision cloud in Revit?
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The Revision Cloud tool is located under the “Annotate” tab in the top ribbon of the Revit interface.
After clicking on “Annotate”, you can find “Revision Cloud” in the “Detail” panel. Once you’ve selected
this tool, you can draw a revision cloud around the area of the drawing that has been revised. Note that
once drawn, revision clouds can be adjusted or deleted using the “Modify” tab.

12. How do you manage revision clouds in Revit?

Managing revision clouds in Revit involves creating, adjusting, and deleting clouds as needed.
Revision clouds can be created using the “Revision Cloud” tool under the “Annotate” tab. Once
created, revision clouds can be selected and their properties can be adjusted in the “Properties” panel.
This includes changing the revision associated with the cloud, adjusting the cloud’s size or shape, or
changing other properties like line weight or style. Revision clouds can be deleted by selecting them
and pressing the “Delete” key.

13. How do you apply revision to all sheets in Revit?

To apply a revision to all sheets in Revit, you first need to create the revision using the “Revisions”
dialog box accessible from the “View” tab. Once created, this revision can be applied to all sheets by
selecting each sheet in the “Project Browser” panel, then going to the “Properties” panel and clicking
on “Revisions on Sheet”. In the dialog box that appears, select the desired revision from the “Revisions
on Sheet” dropdown and click “Add”. Repeat this process for each sheet to apply the revision to all
sheets.

14. Why I can’t edit my Revit model?

If you can’t edit your Revit model, there could be several reasons. One common issue is that the model
or part of the model is locked because it is part of a group or linked file. In this case, you need to edit
the group or linked file separately. Another issue can be that you don’t have the necessary permissions
to edit the model if it is part of a worksharing project. In this case, you need to request the necessary
permissions from the project administrator. Finally, if your model is not responding or behaving
unexpectedly, there might be a technical issue with your Revit software or computer. In this case, you
might need to troubleshoot or seek technical support.

15. How do I change the date on my revision cloud?

Changing the date on a revision cloud in Revit involves changing the date of the revision associated
with the cloud. To do this, access the “View” tab, then select “Sheet Composition” and click on
“Revisions”. In the Revisions dialog box that appears, select the revision linked to the cloud and
change the “Date” field. Remember to click “OK” to save the changes. Note that this will change the
date for all instances where this revision is used in the project.
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During the check-in process, you can specify a new revision level. Note that you need to have the
necessary permissions to make a revision. Also, consider that changing a revision in Windchill will
affect all instances where that item is used. Therefore, it’s crucial to ensure that the new revision is
accurate and that all stakeholders are informed of the change.

17. How do I change my revision in Creo?

Creo, a 3D CAD software, allows users to manage revisions through its integrated Windchill system.
Changing a revision in Creo involves checking out the item you wish to revise, making the necessary
changes, and then checking the item back in. During the check-in process, you can specify a new
revision level in the properties. Note that you need to have the necessary permissions to make a
revision, and always ensure that the changes made are accurate before finalizing the revision.

18. How do you revise parts in Windchill?

Revising parts in Windchill involves a few steps. First, the part must be checked out for modification.
Once checked out, you can make your changes in the part file. After making changes, the part must be
checked back into the Windchill system. During the check-in process, you have the opportunity to
create a new revision of the part. In the properties, specify the new revision level and provide a
comment detailing the changes made. Remember to save and close the part file after checking it back
in.

19. Can you add a revision to multiple sheets in Revit?

Yes, you can add a revision to multiple sheets in Revit. After creating a revision through the
“Revisions” dialog box (accessible from the “View” tab), you can apply it to multiple sheets. Simply
select each sheet in the “Project Browser” panel, then go to the “Properties” panel and click on
“Revisions on Sheet”. In the dialog box that appears, select the desired revision from the “Revisions on
Sheet” dropdown and click “Add”. Repeat this process for each sheet you want to apply the revision to.

20. How do you edit a family sheet in Revit?

Editing a family sheet in Revit involves accessing the family editor. First, locate the family in the
“Project Browser” panel and right-click on it. Then select “Edit Family”. This will open the family in the
family editor, where you can make your desired changes. After making changes, remember to load the
updated family back into the project. Note that if the family is used in multiple places in the project, all
instances of the family will be updated.

Conclusion

The capacity to edit revision text in Revit is a crucial skill for anyone working in the AEC industry. With
the comprehensive tools offered by Revit, you can efficiently manage and track changes throughout
the lifecycle of your project. This ensures that every stakeholder has access to up-to-date and accurate
project information, fostering better communication and collaboration across your team.

Moreover, by effectively managing revisions in Revit, you’re not just keeping track of changes – you’re
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also contributing to the overall quality and success of your projects. As you continue to grow your Revit
skills, always remember that mastering the basics, such as editing revision text, serves as the
foundation for more advanced capabilities. So, take the time to understand, practice, and apply these
skills, and you’ll be well on your way to becoming a Revit expert.
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