
How to copy a sheet from one project to
another in revit : Ultimate Guide

Description

In the world of architecture and design, Autodesk Revit has emerged as a leading software tool for
building information modeling (BIM). Its ability to facilitate multidisciplinary collaboration and streamline
project workflows makes it invaluable to professionals in the architecture, engineering, and
construction industries. One frequently utilized feature in Revit is the ability to copy sheets from one
project to another. This function aids in maintaining consistency across projects and saves time by
reusing existing work. This article will serve as a comprehensive guide on how to copy a sheet from 
one project to another in Revit.

Revit’s sheet copying feature provides flexibility and efficiency, enabling users to replicate views,
schedules, and more across different projects. Despite its usefulness, the process may seem complex
to new users or even seasoned professionals who haven’t used this feature before. This guide aims to
simplify this process, providing step-by-step instructions and addressing common issues that may arise
during sheet copying. By understanding this feature, you can make the most of Revit’s capabilities,
enhancing your productivity and project quality.

Key Takeaways

1. Revit allows users to copy sheets from one project to another, promoting consistency and saving
time.

2. The process involves copying elements from the source project, using the “Paste Aligned to
Selected Levels” function in the target project.

3. Troubleshooting common issues like missing views, incorrect view references, and compatibility
issues can help ensure successful sheet copying.

4. Additional resources like Autodesk’s Revit tutorials, online courses, and YouTube tutorials can
help users further understand and make the most of Revit.

5. The FAQ section provides detailed responses to common questions about copying sheets and
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other related functions in Revit.

How to Copy a Sheet from One Project to Another in Revit

There are various methods to copy a sheet from one project to another in Revit. This guide will discuss
the most common and effective methods that professionals use. These methods include:

1. Using the “Transfer Project Standards” command
2. Using the “Insert from File” command
3. Using third-party plugins

Before we dive into the specifics, it’s worth noting that each method has its strengths and weaknesses,
and the choice often depends on the complexity of the sheet and the specific needs of the project.

Using the “Transfer Project Standards” Command

The “Transfer Project Standards” command is a built-in feature in Revit that allows you to copy
elements and settings from one project to another. Here’s how you can use it to copy a sheet:

1. Open both the source and target Revit projects.
2. In the target project, navigate to Manage tab > Transfer Project Standards.
3. In the pop-up window, select the source project from the drop-down list.
4. Check the box for Sheets under the list of standards to copy.
5. Click OK to start the copying process.

Please note that this method only transfers the sheet and its properties, but not the views on the sheet.

Using the “Insert from File” Command

The “Insert from File” command can also be used to copy sheets from one project to another. This
method works best when you need to copy both the sheet and the views on it. Here are the steps:

1. Open the source project.
2. Navigate to File > Save As > Library > View Template.
3. In the pop-up window, select the views you want to save and click OK.
4. Open the target project.
5. Navigate to Insert > Insert from File > Insert Views from File.
6. Select the view template file you just saved and click Open.

This will import both the sheet and the views on it to your target project.

Using Third-Party Plugins

There are several third-party plugins that can help you copy a sheet from one project to another in
Revit. Some popular ones include:

1. Ideate Explorer: This plugin provides a simple and effective way to copy sheets along with their
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views.
2. CADDaddy: This plugin can copy not only sheets and views, but also dimensions, text, and other

elements.

Each plugin has its own process for copying a sheet. Be sure to read the documentation for your
chosen plugin to understand how to use it effectively.

Best Practices for Copying Sheets in Revit

In addition to the specific steps above, there are a few best practices to keep in mind when copying
sheets in Revit:

Clean up your sheets: Before copying a sheet, make sure it is clean and free of unnecessary
elements. This can help reduce the chance of errors during the copy process.
Organize your views: If you have many views on a sheet, it’s a good idea to organize them into
a logical order before copying the sheet. This can make it easier to manage the copied sheet in
the target project.
Check your work: After copying a sheet, always double-check it in the target project to ensure
everything has copied over correctly. Be especially mindful of view references and annotations,
which can sometimes get lost in the transfer.

Troubleshooting Common Issues When Copying Sheets in
Revit

Occasionally, you might run into some issues when copying sheets between Revit projects. Here are
some common problems and their solutions:

1. Missing views or elements: If a view or element is missing on the copied sheet, it’s possible
that it wasn’t included in the transfer. Try repeating the copying process and make sure all
necessary elements are selected.

2. Incorrect view references: Sometimes, view references can get mixed up during the copy
process. To fix this, you may need to manually adjust the references in the target project.

3. Compatibility issues: If you’re having trouble copying a sheet from a newer version of Revit to
an older version, it could be due to compatibility issues. In this case, you might need to upgrade
the older project to a newer version of Revit.

If you’re still having trouble, there are many resources available online, such as Autodesk’s Revit
Forums and the Revit User’s Group on LinkedIn, where you can ask for help and advice from other
Revit users.

Learning More About Revit

If you’re interested in learning more about Revit, there are plenty of resources available. Here are a
few suggestions:
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1. Autodesk’s official Revit tutorials: These are free, step-by-step guides provided by the
creators of Revit. They cover a wide range of topics, from basic navigation to advanced modeling
techniques. You can find them on Autodesk’s official website.

2. Online courses: Websites like Coursera, Udemy, and LinkedIn Learning offer a variety of Revit
courses for different skill levels. These courses are typically taught by industry professionals and
often include hands-on projects.

3. YouTube tutorials: There are many Revit users who share their knowledge and expertise on
YouTube. Channels like Balkan Architect, The Revit Kid, and Revit Pure are particularly popular :

Remember, copying a sheet from one project to another in Revit is just one aspect of this powerful
software. With practice and dedication, you can master many other aspects of Revit and greatly
enhance your productivity in the field of architecture, construction, and engineering.

FAQ: How to copy a sheet from one project to another in revit?

1. Can you copy a view from one project to another in Revit?

Yes, you can copy a view from one project to another in Revit. This can be achieved by saving the
view as a View Template in the source project and then inserting it from file in the target project. You
can also use the “Transfer Project Standards” command to move the view settings from one project to
another.

2. How do I copy a drafting view from one project to another?

Drafting views can be copied by utilizing the “Insert from File” command. You first need to save the
drafting view as a Drafting View file in the source project. Then, in the target project, you can use the
“Insert from File” command to import the Drafting View file.

3. How do you duplicate a sheet with a view in Revit?

To duplicate a sheet with a view, first create a new sheet in your project. Then, use the “Duplicate
View” command in the View tab to duplicate the desired view. Once duplicated, you can drag and drop
the duplicated view onto the new sheet.

4. How do you duplicate a sheet in Revit 2021?

In Revit 2021, duplicating a sheet involves creating a new sheet and then manually copying the
contents from the existing sheet to the new one. Unfortunately, Revit 2021 does not currently support
the direct duplication of sheets.

5. How do you duplicate multiple sheets in Revit?

Duplicating multiple sheets in Revit requires duplicating each sheet individually. After creating a new
sheet, you can select and copy the contents from the source sheet, and then paste them onto the new
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sheet.

6. What is the difference between duplicate and duplicate with detailing in Revit?

The “Duplicate” command creates a copy of the view without any detailing elements, like dimensions,
text notes, and detail lines. On the other hand, “Duplicate with Detailing” creates a copy of the view
including all the detailing elements.

7. How do you duplicate a schedule in Revit?

To duplicate a schedule in Revit, you need to select the schedule in the Project Browser, right-click and
select “Duplicate”. This will create a copy of the schedule with the same fields and filters.

8. How do you sort a view in Revit?

You can sort views in Revit by going to the Project Browser, right-clicking on the category of views you
wish to sort, and selecting “Sort by” from the context menu. You can then choose to sort by name,
type, associated level, phase, or family and type.

9. How do I update my Revit?

To update Revit, you can use the Autodesk Desktop App, which should be installed with your Revit
software. Open the app, go to the “My Updates” tab, and you should see available updates for Revit.
Click on “Install” to start the updating process.

10. What is Revit 2021?

Revit 2021 is a version of Autodesk’s Revit software released in 2020. It introduced several new
features and enhancements such as generative design tools, slanted walls support, and improvements
to MEP and structural modeling.

11. What does duplicate in Revit mean?

“Duplicate” in Revit means creating a copy of a view, sheet, or other elements. This is useful when you
want to make changes to a view or sheet without altering the original.

12. What is duplicate as Dependant Revit?

“Duplicate as Dependent” in Revit creates a copy of a view that is linked to the original view. Any
changes made to the model in the original view will also appear in the dependent view. However, you 
can adjust the crop region, hide or isolate elements, and add detailing and annotations in the 
dependent view without affecting the original view.

13. How do you duplicate independents in Revit?
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You can create multiple independent views by using the “Duplicate” or “Duplicate with Detailing”
command. These duplicates are independent, meaning changes to the model in one view won’t affect
the other views. However, changes to the model itself (like moving a wall) will appear in all views, as
they all reference the same model.

14. How do I move a schedule from one project to another in Revit?

To move a schedule from one project to another, you need to export the schedule to a text file and
then import it to the target project. To do this, select the schedule in the source project, go to the “File”
menu, select “Export”, choose “Reports”, and then “Schedule”. In the target project, go to the “File”
menu, select “Import/Link”, and then “Schedules”.

15. How do I import a Revit schedule?

To import a schedule in Revit, go to the “File” menu, select “Import/Link”, and then “Schedules”.
Navigate to the location of your exported schedule file, select it, and click “Open”. The schedule will
then be imported into your project.

16. Can you duplicate a key schedule in Revit?

Yes, you can duplicate a key schedule in Revit. Simply select the key schedule in the Project Browser,
right-click, and choose “Duplicate”. This will create a new key schedule with the same parameters as
the original.

17. How do you manage sheets in Revit?

Sheets in Revit are managed through the Project Browser. Here, you can create, duplicate, delete, and
reorder sheets. You can also create sheet sets for better organization, and use the “Browser
Organization” command to sort and group sheets based on specific criteria.

18. How do you categorize sheets in Revit?

Sheets in Revit can be categorized by using the “Browser Organization” command. This allows you to
create custom categories based on parameters like sheet number, sheet name, or custom parameters.
Once you’ve set up your categories, Revit will automatically sort your sheets into these categories in
the Project Browser.

19. How do you create a sheet category in Revit?

To create a sheet category in Revit, go to the Project Browser, right-click on “Sheets”, and select
“Browser Organization”. In the dialog box, click “New…”, give your new category a name, and define
the rules for the category based on sheet parameters. Click “OK” to create the category.
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20. Can I have two versions of Revit on my computer?

Yes, you can have multiple versions of Revit installed on your computer at the same time. This can be
helpful if you need to work with files that were created in different versions of Revit. However,
remember that files created or saved in a newer version of Revit cannot be opened in an older version.

Conclusion

Mastering the art of copying sheets from one project to another in Revit is a valuable skill that can
significantly enhance your efficiency and productivity. By following the steps outlined in this guide,
you’ll be able to streamline your project workflows and foster greater consistency across your projects.
Additionally, understanding how to troubleshoot common issues ensures that you can effectively utilize
this feature under various circumstances.

In the ever-evolving landscape of architectural design, continual learning is key. Remember that this
guide is just one resource in your learning journey. By exploring additional resources and continually
practicing within Revit, you’ll be able to unlock the full potential of this powerful software. Whether
you’re a new user or a seasoned professional, there’s always more to learn and discover in the world
of Revit. With persistence and dedication, you’ll continue to grow your skills and elevate your work to
new heights.
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