
How to bring objects to front in Revit : The
Comprehensive Guide

Description

Autodesk Revit has revolutionized the world of building design and construction. With its robust and
versatile functionality, it allows professionals to create and manage complex 3D models with precision
and ease. Yet, just like with any powerful tool, there can be a learning curve involved. One of the
challenges users often face is effectively managing objects within their designs – particularly when it
comes to ‘bringing objects to the front’. While Revit doesn’t employ a traditional layering system like
some 2D design software, it does offer a range of methods to control object visibility.

In this comprehensive guide, we’ll delve into these methods, breaking down the steps involved in
bringing objects to the front in Revit. We’ll cover everything from detail items to view depth, worksets,
phasing, filters, and view templates. Whether you’re a Revit beginner or an experienced user looking to
brush up on your skills, this guide is designed to help you navigate the process with confidence and
ease.

Key Takeaways
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1. The concept of ‘bringing objects to the front’ in Revit is handled through object categorization,
visibility/graphic overrides, detail items, view depth, worksets, phasing, filters, and view templates.

2. Detail items can be brought to the front by selecting and using the ‘Bring to Front’ option in the
‘Arrange’ panel.

3. 3D object visibility is controlled by the ‘View Depth’ property in the ‘Properties’ panel.
4. Worksets can help control object visibility, especially in collaborative projects.
5. Phasing and filters can be used to manage visibility of objects representing different stages of the

project.
6. The display order of overlapping 2D elements can be controlled through context menu options.
7. View templates and visibility/graphic overrides offer powerful tools for managing object visibility

across different views.

How to Bring Objects to Front in Revit

In Revit, objects are organized into categories which determine the object’s visibility and graphics.
However, the concept of ‘bringing to front’ or ‘sending to back’ as in traditional 2D design software
doesn’t directly apply. Instead, Revit uses a hierarchy based on the category of objects, and the
visibility of objects can also be managed through the ‘Visibility/Graphics Overrides’ settings.

Here’s a general step-by-step guide to adjust visibility settings:

1. Open the desired view.
2. Navigate to the Properties panel on the left-hand side.
3. Under Graphics, click on Visibility/Graphics.
4. In the Visibility/Graphics Overrides dialog box, you can adjust the visibility of different

categories of objects.

However, this process can be more complex depending on the specific type of objects and the view
you’re working with. Let’s break down some different scenarios and solutions.

1. Bringing Detail Items to the Front

Detail items are 2D elements that you add to your views in Revit to provide more information or clarity.
They can be lines, symbols, filled regions, etc. To bring a detail item to the front:

1. Select the detail item.
2. Go to Modify | Detail Items tab > Arrange panel > Bring to Front.

2. Managing View Depth for 3D Objects

In 3D views, objects do not have an inherent front or back order. However, you can use the ‘View
Depth’ property to manage the display of objects. The ‘View Depth’ property allows you to display
certain objects beyond the cut plane of a view.

To use ‘View Depth’:
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1. Open the desired view.
2. In the Properties panel, under Extents, you can adjust the View Depth property.

3. Using Worksets to Control Object Visibility

Worksets are a feature in Revit that allow multiple users to collaborate on a Revit project. They can
also be used to control the visibility of objects. You can create a new workset for the objects you want
to bring to the front, and then manage the visibility of that workset.

To create a new workset:

1. Go to the Collaborate tab > Worksets panel > Worksets.
2. In the Worksets dialog box, click New to create a new workset.
3. Assign the objects you want to bring to the front to the new workset.

You can then control the visibility of that workset in different views by going to the 
Visibility/Graphics Overrides dialog box.

4. Utilizing Phasing and Filters

Revit’s phasing feature allows you to represent different stages of a project (such as Existing,
Demolition, or New Construction). You can use phasing along with filters to control the visibility of
objects.

To use phasing and filters:

1. Create a new phase filter under the Manage tab > Phasing panel > Phase Filters. 2. Assign 
the objects you want to bring to the front to the desired phase.

3. In the Visibility/Graphics Overrides dialog box, you can set the phase filter and adjust
the visibility settings for each phase.

This can be especially useful in complex projects where you need to manage the visibility of many
different elements representing different stages of the project.

5. Controlling the Display Order of Overlapping Elements

For overlapping 2D elements in the same category (for example, two filled regions or two detail lines),
you can control the display order by right-clicking on the element and choosing Bring to Front or 
Send to Back from the context menu.

However, remember that this only applies to elements in the same category, and only in the same
view. For elements in different categories or in different views, you’ll need to use other methods like
those described above.

6. Using View Templates and Visibility/Graphics Overrides
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View templates and the Visibility/Graphics Overrides settings are powerful tools for
managing the visibility of objects in Revit. You can create a view template with specific visibility settings
and then apply that template to different views.

To create a view template:

1. Open the desired view.
2. Go to the View tab > Graphics panel > View Templates drop-down > Create Template 

from Current View.
3. In the New View Template dialog box, you can adjust the visibility settings for different

categories of objects.

Then, to apply the view template to a view:

1. Open the view.
2. Go to the Properties panel > Identity Data > View Template.
3. Choose the desired view template from the drop-down menu.

With these methods, you should be able to bring virtually any object to the front in Revit, whether it’s a
2D detail item or a 3D building element.

FAQ: How to bring objects to front in revit

1. How do you bring to front in AutoCAD?

To bring an object to the front in AutoCAD, you can use the “Bring to Front” command. First, select the
object you want to bring to the front, then right-click and choose “Bring to Front” from the context menu.
You can also use the “Draw Order” command to adjust the order of objects on the screen.

2. How do you pin something in Revit?

To pin an object in Revit, select the object you want to pin and click the “Pin” button in the Modify tab of
the ribbon. Alternatively, you can right-click on the object and choose “Pin” from the context menu.
Pinned objects will remain in their current location even if you move or modify other objects around
them.

3. How do I enter a bearing in Revit?

To enter a bearing in Revit, you can use the “Angle” parameter. First, select the object you want to set
the bearing for, then open the Properties palette and scroll down to find the “Angle” parameter. Enter
the bearing value in the format of degrees, minutes, and seconds, separated by commas. For example,
to set a bearing of N45°30’00?E, you would enter “45,30,0” in the Angle parameter.

4. How do you drag in Revit?

To drag an object in Revit, select the object you want to move, then click and drag it to the new
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location. You can also use the arrow keys to nudge the object in small increments. If you want to move
an object in a specific direction, you can use the “Move” command from the Modify tab of the ribbon.

5. How do you move an object to origin in Revit?

To move an object to the origin in Revit, you can use the “Move to Origin” command. First, select the
object you want to move, then right-click and choose “Move to Origin” from the context menu.
Alternatively, you can use the “Move” command and snap the object to the origin point.

6. How do you vertically move furniture in Revit?

To vertically move furniture in Revit, you can use the “Align” command. First, select the furniture object
you want to move, then click the “Align” button in the Modify tab of the ribbon. Choose the “Vertical”
option and then select the reference point you want to align the object to. You can also use the “Move”
command and set the Z-axis value in the Properties palette to adjust the object’s height.

7. How do you move blocks in Revit?

To move blocks in Revit, you can use the “Move” command. First, select the block you want to move,
then click the “Move” button in the Modify tab of the ribbon. Choose the base point of the block and
then select the new location for the block. You can also use the arrow keys to nudge the block in small
increments.

8. How do I make a filled region transparent in Revit?

To make a filled region transparent in Revit, you can adjust the “Transparency” parameter. First, select
the filled region you want to make transparent, then open the Properties palette and scroll down to find
the “Transparency” parameter. Enter a value between 0 and 100, where 0 is completely opaque and
100 is completely transparent.

9. What is the difference between overlay and attachment in Revit?

In Revit, “Overlay” and “Attachment” refer to the way a linked file is displayed in the host file. An
“Overlay” linked file is displayed on top of the host file, while an “Attachment” linked file is displayed 
behind the host file. This can be useful for managing complex projects with multiple linked files. 
Overlay files are typically used for elements that need to be visible and editable on top of the host file, 
such as floor plans or furniture. Attachment files are typically used for elements that are referenced but 
not edited in the host file, such as a site plan or a background image.

10. How do I use underlay in Revit?

To use an underlay in Revit, first, open the view you want to display the underlay in. Then, click the
“View” tab in the ribbon and select “Underlay.” Choose the desired underlay from the list and adjust the
settings as needed. Underlays can be used to display a reference file or an underlying view as a
background to the current view.
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11. How do you select a pinned object in Revit?

To select a pinned object in Revit, you can use the “Tab” key. Press the “Tab” key to cycle through the
objects in the current view, including pinned objects. Alternatively, you can use the “Select by ID”
command from the Modify tab of the ribbon and enter the ID number of the pinned object.

12. How do you get to the front of Bricscad?

To bring an object to the front in Bricscad, you can use the “Bring to Front” command. First, select the
object you want to bring to the front, then right-click and choose “Bring to Front” from the context menu.
You can also use the “Draw Order” command to adjust the order of objects on the screen.

13. How do you put an object on top of another in AutoCAD?

To put an object on top of another in AutoCAD, you can use the “Draw Order” command. First, select
the object you want to bring to the front, then right-click and choose “Draw Order” from the context
menu. Choose the “Bring to Front” option to move the object to the top of the draw order.

14. How do you move an object backwards in AutoCAD?

To move an object backwards in AutoCAD, you can use the “Draw Order” command. First, select the
object you want to move, then right-click and choose “Draw Order” from the context menu. Choose the
“Send to Back” option to move the object to the bottom of the draw order.

15. How do you pin and unpin in Revit?

To pin an object in Revit, select the object you want to pin and click the “Pin” button in the Modify tab of
the ribbon. To unpin an object, select the pinned object and click the “Unpin” button in the Modify tab of
the ribbon.

16. How do you lock a drawing in Revit?

To lock a drawing in Revit, you can use the “Protect” command. First, select the elements you want to
protect, then click the “Protect” button in the Modify tab of the ribbon. Choose the level of protection
you want to apply and then click “OK.” Protected elements cannot be modified or deleted without first
removing the protection.

17. How do I pin a DWG in Revit?

To pin a DWG file in Revit, first, insert the DWG file as a link into the Revit project. Then, select the
linked file and click the “Pin” button in the Modify tab of the ribbon. Pinned linked files will remain in
their current location even if you move or modify other objects around them.

18. How do you enter bearings and distances in Revit?
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To enter bearings and distances in Revit, you can use the “Angle” and “Distance” parameters. First,
select the object you want to set the bearing and distance for, then open the Properties palette and
scroll down to find the “Angle” and “Distance” parameters. Enter the bearing value in the format of
degrees, minutes, and seconds, separated by commas. For the distance, enter the value in the units
specified in the project settings, such as feet or meters.

19. How do you create boundaries in Revit?

To create boundaries in Revit, you can use the “Boundary” command. First, select the elements that
will define the boundary, such as walls or floors. Then, click the “Boundary” button in the Modify tab of
the ribbon. Choose the boundary type you want to create, such as a room or area boundary, and
adjust the settings as needed.

20. How do you draw CAD bearings?

To draw CAD bearings, you can use the “Line” command in your CAD software. First, set the bearing
value you want to draw, such as N45°30’00?E. Then, start the Line command and click the starting
point for the line. Type in the distance you want to draw and then type in the bearing value in the
format of degrees, minutes, and seconds, separated by commas. Continue clicking the endpoints of
the line segments until you have drawn the desired shape.

Bottom Line

As we’ve explored in this guide, managing object visibility in Revit might initially seem challenging but
it’s a task made simpler with an understanding of Revit’s unique system. There’s no ‘bring to front’
command as in some 2D software, but Revit’s structure based on object categories, along with its
visibility/graphic overrides, offers a versatile and comprehensive approach to controlling object
visibility. By mastering these tools and techniques, you can ensure that your Revit designs are clear,
precise, and visually appealing.

Remember that the key to success in any software is practice and exploration. Don’t be afraid to
experiment with these different methods and find the combination that best suits your needs. As you
become more comfortable with Revit’s system, you’ll find that you have full control over your models,
allowing your creativity and architectural vision to truly shine. After all, in the world of 3D modeling and
building design, the sky is the limit!
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