
How to add folder in project browser in Revit

Description

Welcome to our comprehensive guide on managing and optimizing your project workflow in Autodesk
Revit. Whether you are a beginner or a seasoned professional, understanding how to effectively add
and organize folders in Revit’s Project Browser is crucial to maintaining an efficient and streamlined
work process. This guide will take you through all the steps you need to know, providing detailed
explanations and tips along the way.

Revit is a powerful tool used by architects, engineers, and construction professionals worldwide. It’s
built to support Building Information Modeling (BIM) workflows, which means that it enables users to
design and document a building in 3D while simultaneously capturing important data about its
components. One of Revit’s strengths is its Project Browser, a dynamic and flexible feature that allows
you to navigate and manage the views, sheets, families, and other elements in your project.

Key Takeaways
1. Understanding the Project Browser in Revit and how to add folders is essential for efficient

project management.
2. Revit allows you to create custom Browser Organizations to group and sort views, sheets, and

other elements.
3. Subcategories can be added in Revit to further organize and manage your project components.
4. Separating the Project Browser and Properties enhances your workspace for better productivity.
5. Families and sheets can be organized effectively using parameters and Browser Organizations.
6. Revit provides tools for managing sheets, creating new disciplines, and categorizing views.
7. Understanding the difference between groups and assemblies in Revit can enhance your

modeling and documentation process.
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The Project Browser in Revit is a crucial tool that facilitates the organization and management of
views, schedules, sheets, and other crucial elements in a Revit project. One way to increase
organization and efficiency is by adding folders to your Project Browser. This comprehensive guide will
provide step-by-step instructions on how to do this.

Understanding the Project Browser

Before delving into the process of adding a folder, it’s essential to understand what the Project Browser
is and its role in managing Revit projects.

1. What is the Project Browser? The Project Browser is a panel in Revit that displays the views,
schedules, sheets, families, groups, and linked Revit models in a project. It allows users to
navigate, organize, and manage these components effectively.

2. Why is the Project Browser Important? The Project Browser is vital because it provides a
visual representation of your project’s organization. It’s the central hub where all your project’s
components live. It allows you to access any view or element within your project quickly.

For more information on understanding and using the Project Browser, visit the official Autodesk Revit
User Guide here.

Adding a Folder in Project Browser: Step-by-Step Guide

Follow these steps to add a folder in the Project Browser in Revit:

1. Open the Project Browser: To begin, navigate to the Project Browser on the left side of your
screen. If it isn’t open, you can find it by going to ‘View’ > ‘User Interface’ > ‘Project Browser’.

2. Select the “Views” Section: In the Project Browser, find the “Views” section, which is where
you’ll be adding a new folder.

3. Right-click and Select “New Folder”: Right-click on the “Views” section and select “New
Folder”. A new folder will appear with a default name (usually “New Folder”).

4. Rename the Folder: Right-click on the new folder and select “Rename” to give it a specific name
that suits your project organization.

5. Add Views to the Folder: Now you can drag and drop views into this new folder for better
organization.

The above procedure is the standard way of adding a folder in the Project Browser in Revit. However,
Revit offers a more sophisticated way of managing and categorizing your views through Browser
Organization.

Enhancing Organization with Browser Organization

Browser Organization is a feature in Revit that allows users to create custom arrangements of views,
sheets, and schedules in the Project Browser. Here’s how to use it:

1. Open the Project Browser.
2. Navigate to “Browser Organization”: Right-click on a category (like Views or Sheets), then
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select “Browser Organization”. This will open a new dialog box.
3. Create a New Browser Organization: Click on “New”, give your custom organization a name,

then select “OK”. This creates a new tab in the dialog box.
4. Define Rules for Your Organization: Now, you can set rules for how Revit should group and

sort the views in this category. This is particularly useful for large projects with numerous views
and sheets.

5. Apply the Browser Organization: Once you’re happy with your rules, click “OK” to close the
dialog box. Your new Browser Organization will now be applied to the category you chose, and
you’ll see the changes reflected in the Project Browser.

Remember, you can create different Browser Organizations for different categories. For instance, you
may want one organization for your floor plans and another for your sections.

Let’s take a deeper look at some options available when defining the rules for your Browser
Organization:

Group by Parameter: This option allows you to group views or sheets by any parameter. For
example, you could group all views by their associated level.
Filter by Parameter: This option allows you to limit which views or sheets are shown based on
certain criteria. For example, you could filter out all views that are not associated with a particular
level.
Sort by Parameter: This option allows you to sort the views or sheets in a particular order. For
example, you could sort all views alphabetically by name.

Using View Templates for Enhanced Organization

Another advanced organization tool in Revit is the use of view templates. View templates allow you to
maintain consistent visibility settings, view properties, and even Browser Organization across multiple
views. Once you have defined a view template, you can apply it to existing views or use it when
creating new views.

Here are the steps to create and apply a view template:

1. Create a View Template: Open a view that has the settings you want to use as a template.
Then, go to ‘View’ > ‘View Templates’ > ‘Create Template from Current View’. Give your template
a name and click ‘OK’.

2. Apply a View Template: To apply your new view template to a view, open the view, then go to
‘View’ > ‘View Templates’ > ‘Apply Template’. Select the template you want to apply, then click
‘OK’.

By using view templates, you can ensure that your views are always organized in the same way,
making it easier to find and work with specific views.

FAQ: How to add folder in project browser in Revit

1. How do you add subcategories in project browser Revit?
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Adding subcategories in the project browser in Revit involves creating and using View Filters. View
Filters allow users to define criteria for what should be displayed in a view. First, you’ll need to open
the View Filters dialog box, which can be accessed from the ‘Visibility/Graphics’ or ‘View’ tab. Then,
you’ll create a new filter, define its rules, and apply it to your desired view. This will create a sort of
“sub-category” within your view that only displays elements that meet your defined criteria.

In the second step, you’ll need to name the filter, select the category it applies to, and define the filter
rules. These rules can be based on any parameter associated with the selected category. For
example, you could create a filter for doors that are more than 2m wide.

Finally, once you’ve defined your filter, you’ll apply it to a view. This is done in the ‘Visibility/Graphics
Overrides’ dialog box in the ‘Filters’ tab. After adding your filter, you can define how elements that meet
the filter criteria should be displayed.

2. What is browser organization in Revit?

Browser Organization in Revit is a feature that allows users to customize the arrangement of views,
sheets, and schedules in the Project Browser. It’s a tool to streamline and personalize the way project
components are displayed and accessed.

In the first instance, Browser Organization provides options to group, sort, and filter views, sheets, and
schedules based on parameters. For example, you could group all your floor plan views by the level
they’re associated with.

Secondly, each category (like Views or Sheets) can have its own Browser Organization. This means
you could have one arrangement for your floor plans, and a different arrangement for your sections.
This level of customization makes Browser Organization a powerful tool for managing large projects.

Lastly, Browser Organization is not a one-time setting. You can adjust it as your project evolves, and
you can also have multiple Browser Organizations for a single category and switch between them as
needed.

3. How do you separate project browser and properties in Revit?

In Revit, you can separate the Project Browser and Properties Palette to different areas of your screen
to better suit your workflow. This is achieved by undocking these panels from their default position and
moving them to your preferred location.

The first step is to undock the panels. Hover over the title bar of the panel (where the name ‘Project
Browser’ or ‘Properties’ is displayed), then click and drag. As you drag, you’ll see the panel become
undocked and move with your cursor.

In the next step, you position the undocked panel. You can place it anywhere on your screen – it could
be on a second monitor if you’re using a dual-monitor setup. If you drag it to the edge of the Revit
window, it will re-dock in the new location.
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Lastly, remember that your panel arrangement is saved and will be the same the next time you open
Revit. If you want to reset to the default arrangement, you can do so by going to the ‘View’ tab > ‘User
Interface’ > ‘Reset Interface’.

4. How do I organize files in Revit?

Organizing files in Revit can be achieved in several ways, including the use of folders in the Project
Browser, View Templates, and Browser Organization. However, it’s also essential to maintain good file
management practices outside of Revit.

Firstly, a clear and consistent file naming system is crucial. File names should be informative,
indicating the content of the file and its version. Avoid special characters in file names, as these can
cause issues.

Secondly, consider a logical folder structure on your hard drive or network. This could be based on 
project phases, disciplines, or any other system that suits your workflow. Ensure all team members are 
familiar with this structure and use it consistently.

Lastly, use Revit’s ‘Save As’ function to create versions of your files. This allows you to maintain a
history of your project and revert to older versions if needed. Always make sure to back up your files
regularly, especially before significant changes or milestones.

5. What is project browser in Revit?

The Project Browser in Revit is a navigation tool located on the left side of the interface. It’s essentially
a panel that displays the organization and hierarchy of the different components of a Revit project.

In the first place, the Project Browser provides an overview of all views, schedules, sheets, families,
and groups in your project. This enables you to quickly navigate to different elements without having to
search through your entire project.

Secondly, the Project Browser is not just for navigation. It also allows you to manage and organize
these components. For example, you can add folders, sort views by parameters, and apply Browser
Organizations.

Finally, it’s important to note that the Project Browser reflects the current state of your project. Any
changes made to views, sheets, or other components will be immediately reflected in the Project
Browser.

6. How do I add a sheet category in Revit?

Adding a sheet category in Revit allows you to better organize your sheets in the Project Browser. This
is done through the process of creating a new Browser Organization for sheets.

Firstly, right-click on ‘Sheets’ in the Project Browser and select ‘Browser Organization’. Then, create a
new Browser Organization, give it a name, and define its rules. These rules determine how Revit will
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group and sort your sheets.

Secondly, the rules can be based on any parameter associated with sheets. For example, you could
create a rule to group all sheets by their assigned discipline. This would essentially create a new
“category” of sheets for each discipline.

Lastly, apply the new Browser Organization to your sheets. Now, your sheets will be arranged
according to the rules you defined, making it easier to navigate and manage your sheets.

7. How do you create sub disciplines in Revit?

Creating sub-disciplines in Revit is a process that involves creating custom parameters and using them
to define a new Browser Organization. Sub-disciplines can help to further categorize and organize
views or sheets based on specific project needs.

First, you would create a new parameter that represents your sub-disciplines. This can be done in the
‘Manage’ tab > ‘Project Parameters’. You’ll need to give your parameter a name, select its type, and
define its properties.

Next, you would assign values to this parameter for your views or sheets. This can be done in the
‘Properties’ panel when a view or sheet is active. For instance, if you created a sub-discipline
parameter for views, you could have values like “Structural – Concrete” and “Structural – Steel”.

Finally, you would create a new Browser Organization that groups or sorts views or sheets based on
your sub-discipline parameter. This would result in your views or sheets being organized into sub-
disciplines in the Project Browser.

8. How do you add a view group in Revit?

Adding a view group in Revit involves creating a custom Browser Organization that groups views
based on a specific parameter. View groups can help make your Project Browser more organized and
easier to navigate.

To begin, right-click on ‘Views’ in the Project Browser and select ‘Browser Organization’. In the dialog
box that appears, create a new Browser Organization and define its rules. These rules can be based 
on any parameter associated with views, and they determine how Revit will group your views.

Next, after defining your rules, apply the new Browser Organization to your views. Now, your views will
be grouped according to the rules you set, essentially creating view groups within your Project Browser.

Finally, remember that you can have multiple Browser Organizations for a single category and switch
between them as needed. This allows you to have different view groups for different situations or
project phases.

9. How do I get my Project Browser back in Revit?

In Revit, if your Project Browser disappears or is accidentally closed, you can easily get it back by
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going to the ‘View’ tab on the ribbon, then to ‘User Interface’, and finally, checking ‘Project Browser’.

In the first step, navigate to the ‘View’ tab. This is located in the top menu where you’ll find several
tools related to viewing and navigating your project.

Next, within the ‘View’ tab, find and click on ‘User Interface’. This drop-down menu allows you to
customize which panels and windows are displayed in Revit.

Finally, in the ‘User Interface’ menu, ensure ‘Project Browser’ is checked. If it’s unchecked, click on it to
check it. Your Project Browser should now be displayed. If it was previously undocked, you may need
to drag it back to your preferred location.

10. How do I organize families in Revit?

Families in Revit can be organized in the Project Browser using folders. You can create a new folder
by right-clicking on the ‘Families’ category in the Project Browser and selecting ‘New Folder’. Then, you
can drag and drop families into the folder.

Firstly, you might want to create folders based on the type or purpose of the families. For example, you
could have a folder for furniture families, another for window families, and so on.

Secondly, remember that folders can be nested. This means you could have sub-folders within your
main folders. For instance, within your furniture folder, you could have sub-folders for office furniture,
outdoor furniture, etc.

Lastly, keep in mind that organizing families is not just about the Project Browser. It’s also important to
maintain good file management practices outside of Revit, such as using a clear and consistent
naming system for your family files, and organizing them into folders on your hard drive or network.

11. How do I create a folder in sheets in Revit?

Creating a folder in sheets in Revit involves defining a new Browser Organization for the ‘Sheets’
category in the Project Browser. This Browser Organization would include rules that group sheets
based on a specific parameter, effectively creating a “folder” for each parameter value.

The first step is to right-click on ‘Sheets’ in the Project Browser and select ‘Browser Organization’. In
the dialog box that appears, create a new Browser Organization, give it a name, and define its rules.
These rules can be based on any parameter associated with sheets.

Next, apply the new Browser Organization to your sheets. This will cause your sheets to be grouped
based on the rules you defined. Each group of sheets, defined by a unique parameter value, is
essentially a folder.

Lastly, remember that you can have multiple Browser Organizations for a single category and switch
between them as needed. This means you could have different folders for different stages of your
project or for different types of sheets.
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12. How do you create a library in Revit?

Creating a library in Revit essentially involves creating a collection of families that can be reused in
other projects. This is often achieved by creating a separate Revit file for each family, then organizing
these files into folders on your hard drive or network.

Secondly, organize your family files into folders. The structure of these folders will depend on your
personal or company preferences, but it could be based on the type of family, the discipline they relate
to, or any other system that suits your workflow.

Lastly, ensure all team members are familiar with the library’s structure and how to access it. They
should also know the process for adding new families to the library. This way, your library will continue
to grow and evolve with your projects.

13. What is a Revit container file?

A Revit container file is a single Revit file that contains multiple related components. These
components could be families, groups, or even entire projects. The purpose of a container file is to
keep related elements together so they can be easily reused or transferred between projects.

Firstly, one common type of container file is a family container file. This would be a single Revit file that
contains multiple related families. For instance, you might have a container file for all your door families.

Secondly, another type of container file is a project container file. This could be a Revit file that
contains an entire project, including all its views, sheets, families, and other components. You might
use a project container file as a template for new projects, or to archive a completed project.

Finally, it’s important to note that while container files can be useful, they should be used judiciously.
Having too many elements in a single file can make the file large and slow to open, and it can also
make it harder to find specific elements.

14. How do you manage sheets in Revit?

Managing sheets in Revit involves a combination of strategies, including using the Project Browser,
creating sheet lists, and utilizing plugins for batch operations.

Firstly, the Project Browser is your primary tool for managing sheets. Here, you can create and delete
sheets, organize them into folders, and navigate to them.

Secondly, you can create a Sheet List. This is a type of schedule that lists all the sheets in your project
along with their properties. A sheet list can be a useful tool for reviewing and auditing your sheets.

Lastly, consider using plugins for batch operations. There are several Revit plugins available that can
automate tasks like renaming sheets, duplicating sheets, or adjusting sheet properties. This can be a
significant time-saver when managing a large number of sheets.
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15. How do you create a new discipline?

Creating a new discipline in Revit is accomplished by defining a new Project Parameter and applying it
to views or sheets. This new parameter will represent the discipline, and each view or sheet can be
assigned a value for this parameter.

First, you’ll need to create a new Project Parameter. This can be done in the ‘Manage’ tab > ‘Project
Parameters’. Give your parameter a name (like “Discipline”), select its type, and define its properties.

Next, you’ll assign values to this parameter for your views or sheets. This can be done in the
‘Properties’ panel when a view or sheet is active. For example, if you’re creating new disciplines for
views, you could have values like “Mechanical – HVAC” and “Mechanical – Plumbing”.

Lastly, you’ll create a new Browser Organization that groups or sorts views or sheets based on your
new discipline parameter. This will result in your views or sheets being organized into disciplines in the
Project Browser.

16. What is discipline in Revit?

In Revit, a discipline is a category used to organize and manage views, sheets, and other elements 
within a project. Disciplines typically represent different areas of a construction project such as 
architectural, structural, mechanical, electrical, and plumbing.

Firstly, the discipline assigned to a view or sheet affects several aspects of how that view or sheet
behaves. For example, the visibility and graphical representation of certain elements can vary
depending on the assigned discipline.

Secondly, disciplines can be used to organize views and sheets in the Project Browser. By creating a
Browser Organization based on the discipline parameter, you can group views or sheets by discipline,
making it easier to navigate your project.

Lastly, it’s important to note that while Revit comes with a set of predefined disciplines, you can also
create your own custom disciplines by defining new parameters. This can be useful for tailoring Revit
to the specific needs of your project or firm.

17. How do you categorize views in Revit?

Categorizing views in Revit is achieved by assigning parameters to views and then using these
parameters to define Browser Organizations. This allows you to group and sort views in the Project
Browser based on their parameters.

Initially, you would assign parameters to your views. This can be done in the ‘Properties’ panel when a
view is active. For instance, you could assign a discipline, phase, or sub-discipline to a view.

Next, create a new Browser Organization that groups or sorts views based on the parameter you
chose. This can be done by right-clicking on ‘Views’ in the Project Browser and selecting ‘Browser

CADDIKT
https://caddikt.com/

https://c
addikt.com/

Page 9
https://caddikt.com/



Organization’.

Finally, apply the new Browser Organization to your views. Now, your views will be grouped and sorted
based on the parameter you chose, effectively categorizing your views in the Project Browser.

18. What is the difference between group and assembly in Revit?

In Revit, both groups and assemblies are tools for managing collections of elements, but they are used
in different ways and for different purposes.

Firstly, a group is a collection of elements that are used together and need to be edited as a unit. Once
you create a group, you can insert instances of it in your project. When you edit one instance of a
group, all other instances update automatically.

Secondly, an assembly is similar to a group but is used specifically for construction assemblies, such
as a wall assembly or a furniture assembly. Assemblies can include a parts list or bill of materials, and
they can be scheduled and tagged.

Finally, one key difference between groups and assemblies is that groups can be saved to your library
and used in other projects, while assemblies are specific to the project in which they are created.

19. How do I add a family library in Revit?

Adding a family library in Revit involves creating a collection of family files, organizing them into
folders, and then loading them into your projects as needed.

The first step is to create your families. Each family should be versatile, parametric, and saved as a
separate Revit file with a clear and informative name.

Next, organize your family files into folders. This could be based on the type of family, the discipline
they relate to, or any other system that suits your workflow.

Finally, to add a family from your library to a project, you would go to the ‘Insert’ tab, click ‘Load
Family’, navigate to the family file in your library, and click ‘Open’. The family will then be available to
use in your project.

20. Where is the family library in Revit?

The family library in Revit isn’t a specific location within the software. Rather, it’s a collection of family
files that are stored on your hard drive or network. You can access these files through the ‘Load
Family’ function in Revit.

Firstly, when you click ‘Load Family’ in the ‘Insert’ tab, Revit will open a file dialog box. This dialog box 
will initially show the default Revit families library, which is located in your Revit installation folder.
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Secondly, if you have created your own custom families, you would navigate to the location on your
hard drive or network where those families are stored. You can then select the family you want to load
into your project and click ‘Open’.

Lastly, remember that managing your family library involves more than just knowing where it is. It’s
also important to maintain a clear and consistent file naming system, and to keep your families
organized in folders. This will make it easier to find and load the right family when you need it.

Conclusion

Revit’s flexibility and depth can be a double-edged sword. On the one hand, it allows for tremendous
control and precision in your architectural designs. On the other, it can be overwhelming due to its
complexity. However, by understanding and effectively utilizing features like the Project Browser, you
can significantly streamline your workflow, making the management of views, sheets, and other
elements much more manageable.

To conclude, mastering the Project Browser and its capabilities will significantly enhance your
efficiency and productivity in Revit. It not only aids in the organization of your project components but
also provides a clear overview of your project’s structure. With this guide, you should be well on your
way to becoming a more proficient and confident Revit user. Remember, practice is key, so keep
exploring and experimenting with these features to discover what works best for you and your specific
workflow.
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